HDU-6024-Building Shops(又是一道DP)

Building Shops

Problem Description

HDU’s n classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these n classrooms.

The total cost consists of two parts. Building a candy shop at classroom i would have some cost ci. For every classroom P without any candy shop, then the distance between P and the rightmost classroom with a candy shop on P’s left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.

Input

The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer n(1≤n≤3000), denoting the number of the classrooms.
In the following n lines, each line contains two integers xi,ci(−109≤xi,ci≤109), denoting the coordinate of the i-th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.

Output

For each test case, print a single line containing an integer, denoting the minimal cost.

Sample Input

3
1 2
2 3
3 4
4
1 7
3 1
5 10
6 1
 

Sample Output

5
11

解题思路:

对于每一个位置(第一个位置必开商店),枚举他开商店或者不开商店。也就是的dp【i】【1】和dp【i】【0】。然后对于dp【i】【1】很简单,前一个加上cost,而对于dp【i】【0】,枚举从0 ~ i-1 的位置开商店,然后计算距离。计算距离由于不是连续的,只能计算所有j+1 ~ i位置到 j位置距离的总和。反向从i-1 枚举 到 0 位置,这样没往前移一位,就+上(i-j)*(nd[j+1].pos-nd[j].pos) 的距离,因为j-i位置总共有 i-j 个点,每个点都需要向前移动(nd[j+1].pos-nd[j].pos) 的距离。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
using namespace std;
typedef long long ll;
const int mod = 1e9+7;
const int N = 1e6+10;
struct node{
    ll pos;
    ll cost;
}nd[N];
ll dp[N][2];
ll sum[N];

bool cmp(node a1,node a2)
{
    return a1.pos < a2.pos;
}

int main()
{
    int n;
    while(cin>>n)
    {
        for(int i = 0 ; i < n ; i ++)
        {
            cin>>nd[i].pos>>nd[i].cost;
        }
        // 对点位置进行排序
        sort(nd,nd+n,cmp);
        dp[0][1] = nd[0].cost;
        dp[0][0] = nd[0].cost;
        for(int i = 1 ; i < n ; i ++)
        {
            dp[i][1] = min(dp[i-1][0],dp[i-1][1])+nd[i].cost;
            dp[i][0] = dp[i-1][1]+nd[i].pos-nd[i-1].pos;
            ll tmp = nd[i].pos-nd[i-1].pos;
            for(int j = i-2 ; j >= 0 ; j --)
            {
            	// 加上目前所有点移动的距离和
                tmp += (i-j)*(nd[j+1].pos-nd[j].pos);
                dp[i][0] = min(dp[j][1]+tmp,dp[i][0]);
            }
        }
        cout<<min(dp[n-1][1],dp[n-1][0])<<endl;
    }
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值