POJ-1463-Strategic game(树形DP)

Strategic game

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

For example for the tree:
在这里插入图片描述

the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 … node_identifiernumber_of_roads
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input


4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output


1
2

解题思路:

树形DP入门水题。
给定一棵树。可以放置哨兵,一个哨兵可以巡视到距离为1的点。最少放多少个哨兵可以巡视整棵树。
每个点两个状态,dfs利用子树的状态进行转移就行了。

AC代码:

//#include<bits/stdc++.h>
#include <iostream>
#include <cstdio>
#include <cstring>
#include <math.h>
#include <algorithm>
#include <map>
#include <queue>
#include <deque>
#define ios std::ios::sync_with_stdio(false)
#define int long long
using namespace std;
const int N = 3e5+10;
struct node{
    int val;
    vector<int> to;
}nodes[N];
int dp[N][2];
int n;

void dfs(int pos,int pre)
{
    int sz = nodes[pos].to.size();
    for(int i = 0 ; i <  sz ; i ++)
        if(nodes[pos].to[i] != pre)
            dfs(nodes[pos].to[i],pos);
    dp[pos][0] = 0;
    for(int i = 0 ; i < sz ; i ++)
        if(nodes[pos].to[i] != pre)
            dp[pos][0] += dp[nodes[pos].to[i]][1];
    dp[pos][1] = 1;
    for(int i = 0 ; i < sz ; i ++)
        if(nodes[pos].to[i] != pre)
            dp[pos][1] += min(dp[nodes[pos].to[i]][1],dp[nodes[pos].to[i]][0]);
}

signed  main()
{
    char buf;
    while(~scanf("%lld",&n))
    {
        for(int i = 0 ; i < n; i ++)
            nodes[i].to.clear();
        for(int i = 0 ; i < n; i ++)
        {
            int x,m;
            scanf("%lld%c%c%lld%c",&x,&buf,&buf,&m,&buf);
            for(int j = 0 ; j < m ; j ++)
            {
                int y;
                scanf("%lld",&y);
                nodes[x].to.push_back(y);
                nodes[y].to.push_back(x);
            }
        }
        dfs(0,-1);
        cout<<min(dp[0][0],dp[0][1])<<endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值