poj3348——求凸包面积

题目链接:http://poj.org/problem?id=3348

Your friend to the south is interested in building fences and turning plowshares into swords. In order to help with his overseas adventure, they are forced to save money on buying fence posts by using trees as fence posts wherever possible. Given the locations of some trees, you are to help farmers try to create the largest pasture that is possible. Not all the trees will need to be used.

However, because you will oversee the construction of the pasture yourself, all the farmers want to know is how many cows they can put in the pasture. It is well known that a cow needs at least 50 square metres of pasture to survive.

Input

The first line of input contains a single integer, n (1 ≤ n ≤ 10000), containing the number of trees that grow on the available land. The next n lines contain the integer coordinates of each tree given as two integers x and y separated by one space (where -1000 ≤ x, y ≤ 1000). The integer coordinates correlate exactly to distance in metres (e.g., the distance between coordinate (10; 11) and (11; 11) is one metre).

Output

You are to output a single integer value, the number of cows that can survive on the largest field you can construct using the available trees.

Sample Input

4
0 0
0 101
75 0
75 101

Sample Output

151

题目翻译:

‎你南方的朋友对建造栅栏和把犁股变成剑感兴趣。为了帮助他的海外冒险,他们被迫节省资金购买围栏柱,尽可能使用树木作为栅栏柱。鉴于一些树木的位置,你将帮助农民尝试创造最大的牧场,是可能的。并非所有的树木都需要使用。‎

‎然而,由于你将监督牧场的建设,所有农民想知道的是,他们可以把多少奶牛放在牧场。众所周知,一头牛至少需要50平方米的牧场才能生存。‎

‎输入‎

‎第一行输入包含单个整数‎‎n‎‎ (1 = ‎‎n‎‎ = 10000),包含在可用土地上生长的树的数量。接下来的‎‎n‎‎行包含每个树的整数坐标,给定为两个整数‎‎x,y‎‎由一个空格分隔(其中 -1000 = x,y = 1000)。 ‎‎整数坐标与米的距离(例如,坐标(10;11)和(11;11)之间的距离为1米)。‎

‎输出‎

‎您将输出单个整数值,即可以使用可用树构建的最大场的奶牛数量。‎

 

求出凸包,然后对凸包求面积,面积除以50就是答案。

注意求面积时注意最后的情况(下标)

抛代码(结尾有数据)

#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<iostream>
using namespace std;
const int MAXN=1000;
const double PI=acos(-1.0);

struct point
{
    int x,y;
};
point list[MAXN];
int stack[MAXN],top;

int cross(point p0,point p1,point p2) //计算叉积  p0p1 X p0p2 
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p1.y-p0.y)*(p2.x-p0.x);
}    
double dis(point p1,point p2)  //计算 p1p2的 距离 
{
    return sqrt((double)(p2.x-p1.x)*(p2.x-p1.x)+(p2.y-p1.y)*(p2.y-p1.y));
}    
bool cmp(point p1,point p2) //极角排序函数 , 角度相同则距离小的在前面 
{
    int tmp=cross(list[0],p1,p2);
    if(tmp>0) return true;
    else if(tmp==0&&dis(list[0],p1)<dis(list[0],p2)) return true;
    else return false;
}    
void init(int n) //输入,并把  最左下方的点放在 list[0]  。并且进行极角排序 
{
    int i,k;
    point p0;
    scanf("%d%d",&list[0].x,&list[0].y);
    p0.x=list[0].x;
    p0.y=list[0].y;
    k=0;
    for(i=1;i<n;i++)
    {
        scanf("%d%d",&list[i].x,&list[i].y);
        if( (p0.y>list[i].y) || ((p0.y==list[i].y)&&(p0.x>list[i].x)) )
        {
            p0.x=list[i].x;
            p0.y=list[i].y;
            k=i;
        }    
    }    
    list[k]=list[0];
    list[0]=p0;
    
    sort(list+1,list+n,cmp);
}     

void graham(int n)
{
    int i;
    if(n==1) {top=0;stack[0]=0;}
    if(n==2)
    {
        top=1;
        stack[0]=0;
        stack[1]=1;
    }    
    if(n>2)
    {
        for(i=0;i<=1;i++) stack[i]=i;
        top=1;
        
        for(i=2;i<n;i++)
        {
            while(top>0&&cross(list[stack[top-1]],list[stack[top]],list[i])<=0) top--;
            top++;
            stack[top]=i;
        }    
    }    
}    

int main()
{
    int N;
    while(scanf("%d",&N)!=EOF)
    {
        init(N);
        graham(N);
        if(N<3){
        	printf("0\n");
        	continue;
		}
        int res=0;
        for(int i=0;i<=top;i++)
          res+=cross(list[stack[0]],list[stack[i]],list[stack[(i+1)%(top+1)]]);
        printf("%d\n",res/100);
        
    }    
    return 0;
}
/*
Input
10
-521 -296
-575 -419
-516 -864
-114 -106
187 295
-404 12
840 -852
948 -405
247 704
1 170
Output
31444
*/

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值