poj1106——求半圆覆盖的最大点数

题目链接:poj.org/problem?id=1106

In a wireless network with multiple transmitters sending on the same frequencies, it is often a requirement that signals don't overlap, or at least that they don't conflict. One way of accomplishing this is to restrict a transmitter's coverage area. This problem uses a shielded transmitter that only broadcasts in a semicircle.

A transmitter T is located somewhere on a 1,000 square meter grid. It broadcasts in a semicircular area of radius r. The transmitter may be rotated any amount, but not moved. Given N points anywhere on the grid, compute the maximum number of points that can be simultaneously reached by the transmitter's signal. Figure 1 shows the same data points with two different transmitter rotations.

All input coordinates are integers (0-1000). The radius is a positive real number greater than 0. Points on the boundary of a semicircle are considered within that semicircle. There are 1-150 unique points to examine per transmitter. No points are at the same location as the transmitter.

Input

Input consists of information for one or more independent transmitter problems. Each problem begins with one line containing the (x,y) coordinates of the transmitter followed by the broadcast radius, r. The next line contains the number of points N on the grid, followed by N sets of (x,y) coordinates, one set per line. The end of the input is signalled by a line with a negative radius; the (x,y) values will be present but indeterminate. Figures 1 and 2 represent the data in the first two example data sets below, though they are on different scales. Figures 1a and 2 show transmitter rotations that result in maximal coverage.

Output

For each transmitter, the output contains a single line with the maximum number of points that can be contained in some semicircle.

Sample Input

25 25 3.5
7
25 28
23 27
27 27
24 23
26 23
24 29
26 29
350 200 2.0
5
350 202
350 199
350 198
348 200
352 200
995 995 10.0
4
1000 1000
999 998
990 992
1000 999
100 100 -2.5

Sample Output

3
4
4

题目理解:

给你一个圆的圆心坐标和半径(可能为负),再给你n个点。

然后让你求这个圆的半圆能覆盖的最大点个数。

思路应该很好想,先把点到圆心距离小于半径的点筛选出来,之后暴力枚举所有点,求出在当前点左边,或者和当前点互补的区间内的点的个数,其实就是把求凸包里面的判断一个向量是否在一个向量左边的代码改了一下,不知道为啥直接判断角度不对。

判断折线bc→bc→是不是向ab→ab→的逆时针方向(左边)转向(或者互补)

bool ToLeftTest(Point a, Point b, Point c){
    return Cross(b - a, c - b) >= 0;
}

要特判点数小于等于2的情况,以及半径小于0时的情况。

#include<iostream>
#include<cmath>
#include<algorithm>
#define db double
using namespace std;
const db eps=1e-10;
const db PI=acos(-1.0);
struct Point{
	db x,y;
	Point(db x=0,db y=0):x(x),y(y){}
}p[1005];
Point circle;
db r;
typedef Point Vector;
int sgn(db x){
	if(fabs(x)<=eps) return 0;
	if(x>0) return 1;
	else return -1;
}
db Dist(Point a,Point b){
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
} 
Vector operator-(Point a,Point b){
	return Vector(a.x-b.x,a.y-b.y);
}
db Cross(Point a,Point b){
	return a.x*b.y-a.y*b.x;
}
bool ToLeftTest(Point a, Point b, Point c){
    return Cross(b-a,c-b)>=0;
}
bool cmp(Point p1, Point p2) { //极角排序函数 ,角度相同则距离小的在前面
    int tmp=sgn(Cross(p1-circle,p2-circle));
    if(tmp>0)
        return true;
    if(tmp==0&& Dist(circle,p1)<Dist(circle,p2));
        return true;
    return false;
}
int main(){
	int n;
	while(~scanf("%lf%lf%lf",&circle.x,&circle.y,&r)){
		if(r<0) break;
		scanf("%d",&n);
		int cnt=0;
		for(int i=0;i<n;i++){
			Point pp;
			scanf("%lf%lf",&pp.x,&pp.y);
//			printf("%lf\n",Dist(pp,circle));
			if(r>=Dist(pp,circle))
				p[cnt++]=pp;
		}
		sort(p,p+cnt,cmp);//没有必要进行极角排序 
		if(cnt<=2){//要特判点小于2的情况 
			printf("%d\n",cnt);
			continue;
		}
		int maxn=-1;
		for(int i=0;i<cnt;i++){
			int ans=0;
			for(int j=0;j<cnt;j++)
				if(ToLeftTest(p[i],circle,p[j]))//不知道为啥用角度判过不去 
					ans++;
			maxn=max(ans,maxn);
		}
		printf("%d\n",maxn);
	}
	return 0;
}

 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值