04-树6 Complete Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

 

  • The left subtree of a node contains only nodes with keys less than the node's key.

     

     

  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

     

     

Both the left and right subtrees must also be binary search trees.

 

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

 

/*用到许多关于完美二叉树与
   完全二叉树的性质.
  其次还结合了搜索二叉树。
*/ 

#include <bits/stdc++.h>
using namespace std;
int a[1005],t[1005];
int getleftlength(int n)//计算出n个节点的树其左子树有多少个节点 
{
	int h = (int)(log2(n+1));   //默认向下取整。求出上面的完美二叉树的层数 
	int x = n+1-(int)pow(2,h);  //算出除去完美二叉树后剩余的节点数 
	x = min(x,(int)(pow(2,h-1))); //如果x大于左子树最后一层的最大值,则取最大值,否则不变 
	return (int)(pow(2,h-1))-1+x; //求出左子树的节点个数 
}
void solve(int aleft,int aright,int troot)//从a数组中从aleft到aright中选取正确的数字,并填入到t[troot]中 
{
	int n = aright-aleft+1;//计算有多少个元素 
	if(n==0) return ;
	int l = getleftlength(n);
	t[troot]=a[aleft+l];//填入根节点 
	int leftroot = troot*2+1;//计算左根节点,根据完全二叉树的性质,别忘了加1 
	int rightroot = leftroot+1;//计算右根节点 
	solve(aleft,aleft+l-1,leftroot);//递归处理左右两部分 
	solve(aleft+l+1,aright,rightroot);
 } 
int main(int argc, char** argv) {
	int n,i;
	cin>>n;
	for(int i = 0;i<n;i++) cin>>a[i];
	sort(a,a+n); //按照从小到大排序 
	solve(0,n-1,0);
	for(i = 0;i<n-1;i++) 
	  cout<<t[i]<<" ";
	cout<<t[n-1]<<endl;
	return 0;
}

 

  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值