F - Wormholes (负环判断)——spfa,floyd,bellman_ford

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

//负环判断问题,可以用多种方法,这里给出spfa,bellman_ford,Floyd做法
//bellman_ford做法 
#include <iostream>
#include<cstring>
#include<cstdio>
#define INF 0x3f3f3f
using namespace std;
int n,m,w,C;
int dis[1010];
struct node{
	int s,e,cost;
}p[5005];
bool bellman_floyd()
{
	for(int i = 1;i<=n;i++) dis[i]=INF;
	dis[1]=0;
	for(int i = 1;i<=n-1;i++){
		bool flag=false;
		for(int j = 0;j<C;j++){
			int a=p[j].s;
			int b=p[j].e;
			int cost=p[j].cost;
			if(dis[b]>(dis[a]+cost)&&dis[a]!=INF){
				dis[b]=dis[a]+cost;
				flag=true;
			} 
		}
		if(!flag) break;
	}
	for(int j = 0;j<C;j++){
		if(dis[p[j].e]>(dis[p[j].s]+p[j].cost)&&dis[p[j].s]!=INF){
				dis[p[j].e]=dis[p[j].s]+p[j].cost;
				return true;
			} 
	}
	return false;
}
int main(int argc, char** argv) {
	int ncase; 
	scanf("%d",&ncase);
	while(ncase--)
	{
		scanf("%d %d %d",&n,&m,&w);
		C=0;
		for(int i = 1;i<=m;i++){
			int a,b,cost;
			scanf("%d %d %d",&a,&b,&cost);
			p[C].s=a;
			p[C].e=b;
			p[C++].cost=cost;
			p[C].s=b;
			p[C].e=a;
			p[C++].cost=cost;
		}
		for(int i = 1;i<=w;i++){
			int a,b,cost;
			scanf("%d %d %d",&a,&b,&cost);
			p[C].s=a;
			p[C].e=b;
			p[C++].cost=-cost;
	    }
	    if(bellman_floyd()) printf("YES\n");
	    else printf("NO\n");
	}
	return 0;
}
//Floyd做法 
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
int map[505][505],n,m,k;
bool floyd()
{
	for(int k = 1;k<=n;k++){
		for(int i = 1;i<=n;i++){
			for(int j = 1;j<=n;j++){
				if(map[i][j]>(map[i][k]+map[k][j])){
					map[i][j]=min(map[i][j],map[i][k]+map[k][j]);
					if(map[i][i]<0) return true;
				}
			}
		}
	}
	return false;
 } 
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int a,b,c;
		scanf("%d%d%d",&n,&m,&k);
		memset(map,0x3f3f3f3f,sizeof(map));
		for(int i=1;i<=n;i++)
		    map[i][i]=0;
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(map[a][b]>c)
			   map[a][b]=map[b][a]=c;
		}
		for(int i=1;i<=k;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			map[a][b]=-c;
		}
		if(!floyd())printf("NO\n");
		else printf("YES\n");
	}
	return 0;

}
/*spfa判断负环有两种 
  一种是判断一个点入队的次数是否大于总点数(bfs的原理)
  另一种是判断一点是否出现多次(dfs的原理) 
*/ 
//这里给的是第一种 
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<queue>
#include<vector>
#include<string>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 0xffffff
int n,m,w;
struct e{int to,cost;};
vector<e>v[520];
bool spfa()
{
    int vis[520],dis[520],cnt[520];
    for(int i=0;i<=n;i++){
        vis[i]=0;
		dis[i]=inf;
		cnt[i]=0;
    }
    dis[1]=0;
	vis[1]=1;
	cnt[1]=1;
    queue<int> q;
    q.push(1);
    while(!q.empty()){
        int u=q.front();
        q.pop();
        vis[u]=0;
        int len=v[u].size();
        for(int i=0;i<len;i++)
        {
            int t=v[u][i].to;
            int w=v[u][i].cost;
            if(dis[t]>dis[u]+w)
            {
                dis[t]=dis[u]+w;
                if(!vis[t])
                {
                    vis[t]=1;
                    if(++cnt[t]>=n) return true;
                    q.push(t);
                }
            }
       }
    }
    return false;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&w);
        for(int i=1;i<=n;i++)
            v[i].clear();
        int st,ed,va;
        e a; 
        for(int i=0;i<m;i++){
            scanf("%d%d%d",&st,&ed,&va);
            a.to=ed,a.cost=va;
            v[st].push_back(a);
            a.to=st,a.cost=va;
            v[ed].push_back(a);
        }
        for(int i=0;i<w;i++){
            scanf("%d%d%d",&st,&ed,&va);
            a.to=ed,a.cost=-va;
            v[st].push_back(a);
        }
        int ans=spfa();
        if(ans==1) printf("YES\n");
        else printf("NO\n");
    }

}
//spfa判断一个点是否出现多次 
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<math.h>
#include<queue>
#include<vector>
#include<string>
#include<string.h>
#include<algorithm> 
using namespace std;
#define inf 0xffffff
int n,m,w,flag;
struct edge{
    int des,val;
};
int vis[520],dis[520];
vector<edge> v[520];
void spfa(int k)
{
    if(flag) return ;
    vis[k]=1;
    int len=v[k].size();
    for(int i=0;i<len;i++){
        int now=v[k][i].des;
        if(dis[now]>dis[k]+v[k][i].val){
            dis[now]=dis[k]+v[k][i].val;
            if(vis[now]&&!flag){
                printf("YES\n");
                flag=1;
            }
            else{
                vis[now]=1;
                spfa(now);
            }
        }
    }
    vis[k]=0;
}
void init()
{
    memset(vis,0,sizeof(vis));
	for(int i=2;i<=n;i++) dis[i]=inf;
	dis[1]=0;
	flag=0;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&w);
        for(int i=1;i<=n;i++)
            v[i].clear();
        int st,ed,va;
        edge a;
        for(int i=0;i<m;i++){
            scanf("%d%d%d",&st,&ed,&va);
            a.des=ed,a.val=va;
            v[st].push_back(a);
            a.des=st,a.val=va;
            v[ed].push_back(a);
        }
        for(int i=0;i<w;i++){
            scanf("%d%d%d",&st,&ed,&va);
            a.des=ed,a.val=-va;
            v[st].push_back(a);
        }
        init();
        spfa(1);
        if(!flag) printf("NO\n");
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值