Treasure Exploration ——最小路径覆盖(floyd求传递闭包)

题目链接:http://poj.org/problem?id=2594

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
As an ICPCer, who has excellent programming skill, can your help EUC?

Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output

For each test of the input, print a line containing the least robots needed.

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2

你读过关于宝藏探索的书吗?你看过任何关于宝藏探索的电影吗?你曾经探索过宝藏吗?如果你从未有过这样的经历,你永远不会知道探索宝藏带给你什么乐趣。‎
‎最近,一家名为EUC(探索未知公司)的公司计划探索火星上一个被认为充满宝藏的未知地点。为了科技的快速发展和人类恶劣的环境,EUC派出一些机器人来探索宝藏。‎
‎为了方便它,我们使用由 N 点(这些 N 点从 1 到 N 编号)形成的图形来表示要探索的位置。有些点通过单行道连接,这意味着,通过道路,机器人只能从一端移动到另一端,但不能后退。由于某些未知原因,此图中没有圆圈。机器人可以通过火箭从地球送到任何点。着陆后,机器人可以通过道路访问一些点,并可以选择一些点,这是在其道路上,探索。您应该注意,两个不同的机器人的道路可能包含一些相同的点。‎
‎出于财务原因,EUC希望使用最少的机器人来探索火星上的所有点。‎
‎作为一名ICPCer,谁拥有优秀的编程技能,你能帮助EUC吗?‎

‎输入‎

‎输入将由几个测试用例组成。对于每个测试用例,第一行中给出两个整数 N (1 <= N <= 500) 和 M (0 <= M & lt;= 5000),分别指示图中的点数和单向道路数。以下每行包含两个不同的整数 A 和 B,指示从 A 到 B 的单向(0 <A,B <= N)。输入由一行包含两个零的行终止。‎

‎输出‎

‎对于输入的每个测试,打印一行包含最少机器人所需的行。

 

经典的最小路径覆盖和传递闭包的好题,其实关于最小路径覆盖,有一些特殊的地方,如果有向图有相交边的话就不能简单的最小路径覆盖=节点总数n-最大匹配数,我们需要先跑一个Floyd求出传递闭包,然后对传递闭包求最小路径覆盖。具体可以看这篇文章:最小路径覆盖问题值得注意的地方 .

 

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int G[505][505],visited[505],nxt[505];
int n,m;
int find(int x){
	for(int i = 1;i<=n;++i){
		if(!visited[i]&&G[x][i]){
			visited[i]=1;
			if(nxt[i]==-1||find(nxt[i])){
				nxt[i]=x;
				return 1;
			}
		}
	}
	return 0;
}
int match(){
	memset(nxt,-1,sizeof(nxt));
	int ans=0;
	for(int i = 1;i<=n;++i){
	    memset(visited,0,sizeof(visited));
	    if(find(i)) ans++;
	}
	return ans;
}
void floyd(){
	for(int k = 1;k<=n;++k)
		for(int i = 1;i<=n;++i)
			for(int j = 1;j<=n;++j)
				if(G[i][k]&&G[k][j])
				    G[i][j]=1;
}
int main(int argc, char** argv) {
	while(cin>>n>>m){
		if(!n&&!m) break;
		memset(G,0,sizeof(G));
		for(int i = 1;i<=m;++i){
			int x,y;
			cin>>x>>y;
			G[x][y]=1;
		}
		floyd();
		cout<<n-match()<<endl;
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值