lightoj1027——经典期望问题(设期望求解)

题目链接:https://cn.vjudge.net/problem/LightOJ-1027#author=0

You are in a maze; seeing n doors in front of you in beginning. You can choose any door you like. The probability for choosing a door is equal for all doors.

If you choose the ith door, it can either take you back to the same position where you begun in xi minutes, or can take you out of the maze after xi minutes. If you come back to the same position, you can't remember anything. So, every time you come to the beginning position, you have no past experience.

Now you want to find the expected time to get out of the maze.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer n (1 ≤ n ≤ 100) denoting the number of doors. The next line contains n space separated integers. If the ith integer (xi) is positive, you can assume that the ith door will take you out of maze after xi minutes. If it's negative, then the ith door will take you back to the beginning position after abs(xi) minutes. You can safely assume that 1 ≤ abs(xi) ≤ 10000.

Output

For each case, print the case number and the expected time to get out of the maze. If it's impossible to get out of the maze, print 'inf'. Print the result in p/q format. Where p is the numerator of the result and q is the denominator of the result and they are relatively prime. See the samples for details.

Sample Input

3

 

1

1

 

2

-10 -3

 

3

3 -6 -9

Sample Output

Case 1: 1/1

Case 2: inf

Case 3: 18/1

 

题目翻译:

你在迷宫里;一‎‎开始看到你面前的n扇门你可以选择任何你喜欢的门。选择门的概率是所有门都相等。‎

‎如果你‎‎选择i‎‎门,它可以带你回到相同的位置,你开始在x ‎‎i‎‎分钟,或可以带你走出迷宫后x ‎‎i‎‎分钟。如果你回到同一个位置,你什么都不记得。所以,每次你来到开始的位置,你没有过去的经验。‎

‎现在,你想找到从迷宫中走出的预期时间。‎

‎输入‎

‎输入以整数‎‎T‎‎(=‎‎100)‎‎开头,表示测试用例的数量。‎

‎每个案例包含一个空白行和一个整数‎‎n (1 = n = 100)‎‎表示门数。下一行包含‎‎n‎‎个空格分隔的整数。如果‎‎i‎‎整‎‎数‎‎(x‎‎i‎‎)‎‎为正值,则可以假设 i 门将在‎‎x‎‎i‎‎分钟后带您走出迷宫。 ‎‎ ‎‎如果是负数,则 i 门将在‎‎abs(x‎‎i‎‎)‎‎几分钟后将您带回开始位置。 ‎‎ ‎‎您可以安全地假设 1 ‎‎= abs(x‎‎i‎‎) = 10000‎‎。‎

‎输出‎

‎对于每个案例,打印案例编号和从迷宫中退出的预期时间。如果不可能走出迷宫,‎‎打印"inf"。‎‎以‎‎p/q‎‎格式打印结果。其中‎‎p‎‎是结果的分子,q‎‎是结果的分母,它们相对为质数。有关详细信息,请参阅示例。

 

比较简单而且经典的求期望的问题,这里求期望的方法很经典。

设当前期望时间为E,可以推出:

1.如果可以走出迷宫,期望为sum1/n;

2.如果不可以走出迷宫,期望为(E*num2+sum2)/n

(备注:sum1为能走出迷宫的时间总数,sum2同为不能走出,回到原地的时间总数,num2为不能带你走出迷宫的门的总个数)

综上,可得方程:E = sum1 / n + ( E * num2 + sum2 ) / n;

解得 E = (sum1+sum2)/(n-num2)        注意不要忘记约分!!!

#include <iostream>
#include<cmath>
#include<algorithm> 
using namespace std;
int main(int argc, char** argv) {
	int n;
	int T;
	scanf("%d",&T);
	for(int kcase=1;kcase<=T;kcase++){
		scanf("%d",&n);
		int flag=0;
		int num2=0,sum1=0,sum2=0;
		for(int i=1;i<=n;++i){
			int x;
			scanf("%d",&x);
			if(x>=0)	sum1+=x,flag=1;
			else{
				num2++;
				sum2+=abs(x);
			}
		}
		if(!flag) printf("Case %d: inf\n",kcase);
		else{
			int x=__gcd(sum1+sum2,n-num2);
			printf("Case %d: %d/%d\n",kcase,(sum1+sum2)/x,(n-num2)/x);
		}	
	} 
	return 0;
}

 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值