[LightOJ 1027] A Dangerous Maze (概率与期望)

Description

You are in a maze; seeing n doors in front of you in beginning. You can choose any door you like. The probability for choosing a door is equal for all doors.

If you choose the ith door, it can either take you back to the same position where you begun in xi minutes, or can take you out of the maze after ximinutes. If you come back to the same position, you can't remember anything. So, every time you come to the beginning position, you have no past experience.

Now you want to find the expected time to get out of the maze.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer n (1 ≤ n ≤ 100) denoting the number of doors. The next line contains n space separated integers. If the ithinteger (xi) is positive, you can assume that the ith door will take you out of maze after xi minutes. If it's negative, then the ith door will take you back to the beginning position after abs(xi) minutes. You can safely assume that 1 ≤ abs(xi) ≤ 10000.

Output

For each case, print the case number and the expected time to get out of the maze. If it's impossible to get out of the maze, print 'inf'. Print the result inp/q format. Where p is the numerator of the result and q is the denominator of the result and they are relatively prime. See the samples for details.

Sample Input

3

 

1

1

 

2

-10 -3

 

3

3 -6 -9

Sample Output

Case 1: 1/1

Case 2: inf

Case 3: 18/1


有N扇门,其中有一些门进去以后经过时间x(x以负数给出)后又回到了原点,并且你下一次还可能再次走进这扇门。而另一些则在x时间后能走出迷宫。问走出迷宫的期望时间是多少。

设时间期望为E,走进每扇门的概率是一样的。可以走出迷宫的期望为 (1/n)*xi , 走到回路门的期望为 (1/n)*(xi+E) , 可以理解成浪费了xi 的时间后,又花了期望时间才能走出去。以三个样例为例, E = (1/3)*3 + (1/3)*(6+E) + (1/3)*(9+E) 。这里面用了一点近似。

所以整理一下,就得到 E = sigma(x) + r*E , 其中r为回路门的个数, 所以 ( n-r )*E = sigma(x) 。可以看出n=r,既都是回路门的时候,是走不出迷宫的,应该输出inf。以下依旧是蠢得不行的代码。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <map>
using namespace std;
#define CLR(a) memset(a,0,sizeof(a))
int N;
int gcd(int a,int b)
{
	return b==0?a:gcd(b,a%b);
}

int main()
{
	int T;
	scanf("%d", &T);
	for(int ck=1; ck<=T; ck++)
	{
		scanf("%d", &N);
		int ansl=0,ansr=0,inpt;
		for(int i=1; i<=N; i++)
		{
			scanf("%d", &inpt);
			if(inpt<0)
			{
				ansr++;
				ansl+=-inpt;
			}
			else
			{
				ansl+=inpt;
			}
		}
		printf("Case %d: ", ck);
		if(N==ansr)
		{
			puts("inf");
		}
		else
		{
			int GCD=gcd(ansl, N-ansr);
			printf("%d/%d\n", ansl/GCD, (N-ansr)/GCD);
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值