算法竞赛入门经典(第2版) Score UVa 1585

Score UVa 1585


题目:There is an objective test result such as “OOXXOXXOOO”. An ‘O’ means a correct answer of a problem
and an ‘X’ means a wrong answer. The score of each problem of this test is calculated by itself and
its just previous consecutive ‘O’s only when the answer is correct. For example, the score of the 10th
problem is 3 that is obtained by itself and its two previous consecutive ‘O’s.
Therefore, the score of “OOXXOXXOOO” is 10 which is calculated by “1+2+0+0+1+0+0+1+2+3”.
You are to write a program calculating the scores of test results.

大意为:给出一个由O和 X组成的串(长度为1-80),最多有十个串,统计得分。每个O的得分为目前连续出现的O的个数,X 的得分为0。如OOXXOXXOOO得分为1+2+0+0+1+0+0+1+2+3。

思路:定义一个变量tmp记录连续出现O次数,若为X重新赋值为1。

Sample Input
5
OOXXOXXOOO
OOXXOOXXOO
OXOXOXOXOXOXOX
OOOOOOOOOO
OOOOXOOOOXOOOOX

Sample Output
10
9
7
55
30
#include<stdio.h>
#include<string.h>
#define maxn 85
int main(){
	int T;
	scanf("%d", &T);
	while(T--) {
		int tmp = 1;  //记录连续出现O次数 
		int score = 0;
		char s[maxn];
		memset(s, 0, sizeof(s));
		scanf("%s", s);
		int n = strlen(s); 
		for(int i = 0; i < n; i++) {
			if(s[i] == 'O') { //若为O,tmp++ 
				score += tmp++;
			}
			if(s[i] == 'X') { //若为X,tem赋1 
				tmp = 1;
			}
		}
		printf("%d\n", score);
	}
	return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值