算法竞赛入门经典(第2版) All in All UVa 10340

All in All UVa 10340

—————————————————————————
题目:UVa10340
—————————————————————————

思路:将两个字符串逐位比较,pos记录其位置,若pos=字符串s长度则成功。

**Sample Input**
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

**Sample Output**
Yes
No
Yes
No
#include<bits/stdc++.h>
#define maxn 10000000
using namespace std;
int main() {
	char s[maxn], t[maxn];
	while(scanf("%s%s", s, t) != EOF) {
		int len_S = strlen(s);
		int len_T = strlen(t);
		int pos = 0;
		for(int i = 0; i < len_T; i++) {
			if(t[i] == s[pos]) 
				pos ++;
		}
		if(pos == len_S) {
			printf("Yes\n");
		}
		else printf("No\n");
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值