DNA Sorting (JSU-ZJJ)

题目描述

One measure of “unsortedness” in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence “DAABEC”, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence “AACEDGG” has only one inversion (E and D)–it is nearly sorted–while the sequence “ZWQM” has 6 inversions (it is as unsorted as can be–exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of “sortedness”, from “most sorted” to “least sorted”. All the strings are of the same length.

输入

The first line contains two integers: a positive integer n (0 < n ≤ 50) giving the length of the strings; and a positive integer m (1 < m ≤ 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

输出

Output the list of input strings, arranged from “most sorted” to “least sorted”. If two or more strings are equally sorted, list them in the same order they are in the input.

样例输入

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

样例输出

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

分析:

此题读懂题意后,发现这是一道简单的题目。不过一开始我却想到了去求逆序数的方法(运用分治的方法)。不过我突然可以不用分治, 因为此题的字符串长度不大,不会超时

#include"stdio.h"
#include"string.h"
typedef struct node{
  char a[51];
  long long number;
}node;
int main()
{   char c;
    int M,N;
    node a[101],transfer;
    int i,j,k,l;
    int count;
    while(~scanf("%d%d",&M,&N))
    {   scanf("%c",&c);
        count=0;
        for(i=0;i<N;i++)
            {scanf("%s",a[i].a);
             l=strlen(a[i].a);
             for(j=0;j<M-1;j++)
                for(k=j+1;k<M;k++)
                    if(a[i].a[j]>a[i].a[k])
                       count++;
              a[i].number=count;
              count=0;
            }
     /*   for(i=0;i<N;i++)
             printf("%s %lld\n",a[i].a,a[i].number);*/
        for(i=0;i<N-1;i++)
            for(j=i+1;j<N;j++)
               if(a[i].number>a[j].number)
        {
            transfer=a[i];a[i]=a[j];a[j]=transfer;
        }
        for(i=0;i<N;i++)
            printf("%s\n",a[i].a);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值