DNA Sorting(归并排序求逆序对 )

DNA Sorting

Describe

One measure of “unsortedness” in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence “DAABEC”, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence “AACEDGG” has only one inversion (E and D)—it is nearly sorted—while the sequence “ZWQM” has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of “sortedness”, from “most sorted” to “least sorted”. All the strings are of the same length.

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output
Output the list of input strings, arranged from “most sorted” to “least sorted”. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA

利用归并排序的方式求出各个字符串的逆序数并按照从小到大的顺序排序之后输出对应的字符串。

#include<iostream>
#include<cstring>
#include<algorithm>

using namespace std;

struct node{
    char line[60];
    char cop[60];
    char temp[60];
    int num;
}a[100];
char temp[60];

void merge(int first,int mid,int last,int n);
void mergesort(int first,int last,int n);
bool cmp(const node& a,const node& b)
{
    return a.num<b.num;
}

int main()
{
    int m,n,i;
    cin>>m>>n;
    for(i=0;i<n;i++)
    {
        cin>>a[i].line;
        memcpy(a[i].cop,a[i].line,m);
        mergesort(0,m-1,i);
    }
    sort(a,a+n,cmp);
    for(i=0;i<n;i++)
    {
        cout<<a[i].line<<endl;
    }
    return 0;
}

void merge(int first,int mid,int last,int n)
{
    int i=first,j=mid+1,k=first;
    while(i<=mid&&j<=last)
    {
        if(a[n].cop[i]>a[n].cop[j])
        {
            temp[k++]=a[n].cop[j++];
            a[n].num+=mid-i+1;
        }
        else
        {
            temp[k++]=a[n].cop[i++];
        }
    }
    while(i<=mid) temp[k++]=a[n].cop[i++];
    while(j<=last) temp[k++]=a[n].cop[j++];
    for(i=first;i<=last;i++)
        a[n].cop[i]=temp[i];
}

void mergesort(int first,int last,int n)
{
    if(first<last)
    {
        int mid=(first+last)/2;
        mergesort(first,mid,n);
        mergesort(mid+1,last,n);
        merge(first,mid,last,n);
    }
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值