Windows Message Queue

题目描述:

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.
Input
There’s only one test case in the input. Each line is a command, “GET” or “PUT”, which means getting message or putting message. If the command is “PUT”, there’re one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.
Output
For each “GET” command, output the command getting from the message queue with the name and parameter in one line. If there’s no message in the queue, output “EMPTY QUEUE!”. There’s no output for “PUT” command.
Sample Input
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET
Sample Output
EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!

分析:

本题, 如果用C语言来写的话,是比较繁琐的。并且容易出错,不过如果我们用C++里面的容器进行操作的话, 会发现, 其实这个操作时十分简单的。我们只需要使用优先队列就可以了。

#include"stdio.h"
#include"string.h"
#include"queue"
 using namespace std;
typedef struct node
{
    char name[16];
    int value;
    int priority;
    int dd;、
   //这里是优先队列的最基本排序操作, 也是核心操作。
    bool operator <(const node &a) const
    {   if(priority==a.priority)
              return dd>a.dd;
        return priority>a.priority;
    }
} NEWS;
NEWS news;
priority_queue <NEWS> q;
int main()
{
    long long i,j,k=0;
    char stringA[100];
    NEWS T;
    while(~scanf("%s",stringA))
    {
        if(stringA[0]=='G')
           { if(!q.empty())
             {T=q.top();q.pop();
             printf("%s %d\n",T.name,T.value);
             }
             else
                printf("EMPTY QUEUE!\n");
           }
        else
        {
            scanf("%s%d%d",T.name,&T.value,&T.priority);
            T.dd=k++;
            q.push(T);
        }

    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值