M - Power Strings

题目描述:

Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
题意:给一个字符串S长度不超过10^6,求最大的n使得S由n个相同的字符串a连接而成,如:"ababab"则由n=3个"ab"连接而成,"aaaa"由n=4个"a"连接而成,"abcd"则由n=1个"abcd"连接而成。

分析:

本题的第一反应就是循环节的使用。我们可以发现本题无非就是求出最小循环节,且要保证len% ans==0。如果不等于0,就输出1。
参考博客:http://www.cppblog.com/Davidlrzh/articles/115751.html
代码如下:

#include"stdio.h"
#include"string.h"
     char text[1000001];
     int next[1000001];
void Get_next(char text[],int next[])
{
    int i,j,len;
    next[0]=-1;
    i=0;j=-1;
    len=strlen(text);
    while(i<len)
    {
        if(j==-1||text[i]==text[j])
        {
            i++;j++;
            if(text[i]==text[j])
                next[i]=next[j];
            else
                next[i]=j;
        }
        else
            j=next[j];
    }

}
int main()
{

     int len,i,ans;
     while(~scanf("%s",text))
     {
         if(text[0]=='.')
            break;
         len=strlen(text);
         Get_next(text,next);
         ans=len-next[len];//得到最小循环节
         if(ans!=len&&len%ans==0)//保证此字符串正好由多于一个循环节构成
            printf("%d\n",len/ans);//求出有几个循环节
         else
            printf("%d\n",1);

     }

}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值