A - Power Strings

点击打开链接


Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.



#include <stdio.h>
#include <stdlib.h>
#include <string.h>
char s[1000005], t[1000005];
int next[1000005]; 
int Kmp(char* s, int n, char* t, int m) 
{
    int i = m, j = 0;
    int ans=0;
    while(i < n) 
	{
        if(j == -1 || s[i] == t[j]) 
		{
            ++i; ++j;
            if(j == m) 
            {
            	ans++;
            	j=0;
			}
        }
        else 
            return 0;
    }
      return ans;
}
void getnext(char *t, int m) 
{
    int i = 0, j = 0;
    next[0] = -1; 
	j = next[i];
    while(i < m) 
	{
        if(j == -1 || t[i] == t[j]) 
          next[++i] = ++j;
        else 
          j = next[j];
    }
}
int main()
{
    while(~scanf("%s",s))
    {
    	if(s[0]=='.')
    	  break;
    	int n,m,i,j,ans=0;
        n=strlen(s);
        strcpy(t,s);
        for(i=1;i<=(n/2);i++)
          if(n%i==0)
          {
        	m=i;
        	getnext(t, m);
        	ans=Kmp(s,n,t,m);
			if(ans)
			  break;   
          }
        if(i<=(n/2))
          printf("%d\n",ans+1);
        else
		  printf("1\n");  
	}
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值