打印金字塔 (java实现)

Problem Description
输入n值,打印下列形状的金字塔,其中n代表金字塔的层数。

Input
输入只有一个正整数n。
Output
打印金字塔图形,其中每个数字之间有一个空格。
Sample Input
3
Sample Output
    1
  1 2 1
1 2 3 2 1
Hint
 
Source

 

import java.util.*;
public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int n = sc.nextInt();
        for (int i = 0; i < n; i++) {   // 共有n行
            int k = 0;  // 设置变量保存打印的数字
            for (int j = 0; j < 2*n+2*i-1; ) {  // 前2n+2i-1列为有效列
                if (j < 2*n - 2*i - 2) {    // 每行需要打印空格的列
                    System.out.print(" ");
                    j++;
                } else if (j >= 2*n - 2*i - 2&& j < 2*n-1) {    // 每行需要打印递增数的列
                    if (i == 0){    // 进行判断,防止行末空格
                        System.out.print(++k);
                    }
                    else{
                        System.out.print(++k+" ");
                    }
                    j += 2;     // 因为每个数自带空格,所以占两列
                } else {
                    if (k == 2){    // 进行判断,防止行末空格
                        System.out.print(--k);
                    }
                    else{
                        System.out.print(--k+" ");
                    }
                    j += 2;
                }
            }
            System.out.println();   // 每一行打印完,需要换行
        }
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值