HDU - 6629 string matching

string matching

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 262144/262144 K (Java/Others)

Problem Description

String matching is a common type of problem in computer science. One string matching problem is as following:

Given a string s [ 0 … l e n − 1 ] s[0…len−1] s[0len1], please calculate the length of the longest common prefix of s [ i … l e n − 1 ] s[i…len−1] s[ilen1] and s [ 0 … l e n − 1 ] s[0…len−1] s[0len1] for each i > 0 i>0 i>0.

I believe everyone can do it by brute force.
The pseudo code of the brute force approach is as the following:
Alt
We are wondering, for any given string, what is the number of compare operations invoked if we use the above algorithm. Please tell us the answer before we attempt to run this algorithm.

Input

The first line contains an integer T T T, denoting the number of test cases.
Each test case contains one string in a line consisting of printable ASCII characters except space.

  • 1 ≤ T ≤ 30 1≤T≤30 1T30

  • string length ≤ 1 0 6 ≤10^6 106 for every string

Output

For each test, print an integer in one line indicating the number of compare operations invoked if we run the algorithm in the statement against the input string.

Sample Input

3
_Happy_New_Year_
ywwyww
zjczzzjczjczzzjc

Sample Output

17
7
32

Tips

题意

若使用 BF \text{BF} BF 算法求给定字符串 s [ 0.. l e n − 1 ] s[0..len-1] s[0..len1] 的每一个后缀与其自身的最长前缀,问比较次数的总和。

题解

拓展 KMP \text{KMP} KMP 的裸题,最终的答案为 ∑ i = 1 l e n − 1 [ extend [ i ] + ( i + extend [ i ] &lt; l e n ) ] \sum_{i=1}^{len-1}\left[\text{extend}[i]+(i+\text{extend}[i]&lt;len)\right] i=1len1[extend[i]+(i+extend[i]<len)]

#include <bits/stdc++.h>
using std::max;
typedef long long ll;
const int MAXN=1e6+10;
void pre_EKMP(char x[],int m,int next[]){
    next[0]=m;
    int j=0;
    for (;j+1<m&&x[j]==x[j+1];++j);
    next[1]=j;
    int k=1;
    for (int i=2;i<m;++i){
        int p=next[k]+k-1;
        int L=next[i-k];
        if (i+L<p+1) next[i]=L;
        else{
            for (j=max(0,p-i+1);i+j<m&&x[i+j]==x[j];++j);
            next[i]=j;
            k=i;
        }
    }
}
void EKMP(char x[],int m,char y[],int n,int next[],int extend[]){
    pre_EKMP(x,m,next);
    int j=0;
    for (;j<n&&j<m&&x[j]==y[j];++j);
    extend[0]=j;
    int k=0;
    for (int i=1;i<n;++i){
        int p=extend[k]+k-1;
        int L=next[i-k];
        if (i+L<p+1) extend[i]=L;
        else{
            for (j=max(0,p-i+1);i+j<n&&j<m&&y[i+j]==x[j];++j);
            extend[i]=j;
            k=i;
        }
    }
}
int T;
char str[MAXN];
int next[MAXN],extend[MAXN];
int main(){
    scanf("%d",&T);
    while (T--){
        scanf("%s",str);
        int len=strlen(str);
        EKMP(str,len,str,len,next,extend);
        ll res=0;
        for (int i=1;i<len;++i){
            res+=extend[i];
            if (i+extend[i]<len) ++res;
        }
        printf("%lld\n",res);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值