HDU-1306-String Matching

String Matching

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 776    Accepted Submission(s): 404


Problem Description
It's easy to tell if two words are identical - just check the letters. But how do you tell if two words are almost identical? And how close is "almost"?

There are lots of techniques for approximate word matching. One is to determine the best substring match, which is the number of common letters when the words are compared letter-byletter.

The key to this approach is that the words can overlap in any way. For example, consider the words CAPILLARY and MARSUPIAL. One way to compare them is to overlay them:  

CAPILLARY
MARSUPIAL

There is only one common letter (A). Better is the following overlay:

CAPILLARY
   MARSUPIAL

with two common letters (A and R), but the best is:

  CAPILLARY
MARSUPIAL  

Which has three common letters (P, I and L).

The approximation measure appx(word1, word2) for two words is given by:

common letters * 2
-----------------------------
length(word1) + length(word2)

Thus, for this example, appx(CAPILLARY, MARSUPIAL) = 6 / (9 + 9) = 1/3. Obviously, for any word W appx(W, W) = 1, which is a nice property, while words with no common letters have an appx value of 0.
 

Sample Input
  
  
The input for your program will be a series of words, two per line, until the end-of-file flag of -1. Using the above technique, you are to calculate appx() for the pair of words on the line and print the result. For example: CAR CART TURKEY CHICKEN MONEY POVERTY ROUGH PESKY A A -1 The words will all be uppercase.
 

Sample Output
  
  
Print the value for appx() for each pair as a reduced fraction, like this: appx(CAR,CART) = 6/7 appx(TURKEY,CHICKEN) = 4/13 appx(MONEY,POVERTY) = 1/3 appx(ROUGH,PESKY) = 0 appx(A,A) = 1
 

Recommend
Eddy
 
import java.util.Scanner;

public class String_Matching_1306_201308121604 {
	public static void main(String[] args) {
		Scanner sc = new Scanner (System.in);	
		while(sc.hasNext()){//8919883 2013-08-12 18:34:54 Accepted 1306	109MS	2848K	1342 B	Java	1983210400
			String st = sc.next();
			if(st.equalsIgnoreCase("-1"))
				break;
			String sr = sc.next();
			int stlen = st.length();
			int srlen = sr.length();
           
			int count,max=0,i,j;
			for( i=0; i<stlen; i++){
				 count=0;
				 int h=i;
				for( j=0; j<srlen && h<stlen; ){//正面匹配
					char st1 = st.charAt(h++);
					char sr1 = sr.charAt(j++);
					if(st1==sr1)
						count++;						
				}
				 if(max<count)
				     max=count;
				
			}
			
			for( j=0; j<srlen; j++){
				 count=0;
				 int h=j;
				for(i=0; i<stlen&& h<srlen; ){//反面匹配
					char st1 = st.charAt(i++);
					char sr1 = sr.charAt(h++);
					if(st1==sr1)
						count++;						
				}
				 if(max<count)
				     max=count;
				
			}
			int ss = stlen+srlen;
			if(max==0)
				System.out.println("appx"+"("+st+","+sr+") = "+0);
			else{
				
				if(ss%2*max==0){
					int ss1 = ss/(2*max);
					if(ss1!=1)
						System.out.println("appx"+"("+st+","+sr+") = "+1+"/"+ss1);
					else
						System.out.println("appx"+"("+st+","+sr+") = "+1);
				}		
					
				else{
						System.out.println("appx"+"("+st+","+sr+") = "+2*max+"/"+ss);
				}
			}
			
		}
	}
   
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值