【剑指紫金港】1151 LCA in a Binary Tree 最近公共祖先&DFS

A 1151 LCA in a Binary Tree

题目链接

Problem Description

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and Ais the key. But if Ais one of Uand V, print X is an ancestor of Y. where Xis Aand Yis the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found.or ERROR: V is not found.or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题目大意

给出一棵二叉树的中序遍历序列和先序遍历序列,根据节点a和节点b的值求出节点a和节点b的最近公共祖先的值。

解题思路

看不懂什么LCA算法(又是递增又是tarjian啊…),结合创建二叉树的算法写的,时间上看特别优秀。
在这里插入图片描述

思路就是不断以某个节点mid为中心(从根节点开始搜),将当前这棵树分为左子树和右子树,通过unordered_map快速找到节点mid在中序序列的位置。我们要找节点a、b的最近公共祖先,将a、b在中序序列的位置作为参数x、y传递进dfs中搜索,然后将mid和x、y比较,第一个可以将x和y分到左右两边的mid就是答案。如果不能分成两半就根据x、y和mid的值到当前树的左子树或右子树继续搜索。

AC代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 10005;
int in[maxn],pre[maxn],m,n,a,b;
unordered_map<int,int> key;
int dfs(int x,int y,int inL,int inR,int preL,int preR){
    int mid=key[pre[preL]];
    if((x<mid && mid<y)||(y<mid && mid<x)||(mid==x)||(mid==y)){
        return mid;
    }
    int num=mid-inL;
    if(x<mid && y<mid){
        return dfs(x,y,inL,mid-1,preL+1,preL+num);
    }
    return dfs(x,y,mid+1,inR,preL+num+1,preR);
}
int main(){
    scanf("%d%d",&m,&n);
    for(int i=0;i<n;i++){
        scanf("%d",&in[i]);
        key[in[i]]=i;
    }
    for(int i=0;i<n;i++){
        scanf("%d",&pre[i]);
    }
    while(m--){
        scanf("%d%d",&a,&b);
        if(key.find(a)==key.end()){
            if(key.find(b)==key.end()){
                printf("ERROR: %d and %d are not found.\n",a,b);
                continue;
            }else{
                printf("ERROR: %d is not found.\n",a);
                continue;
            }
        }else if(key.find(b)==key.end()){
            printf("ERROR: %d is not found.\n",b);
            continue;
        }
        int ans=in[dfs(key[a],key[b],0,n-1,0,n-1)];
        if(ans==a){
            printf("%d is an ancestor of %d.\n",a,b);
        }else if(ans==b){
            printf("%d is an ancestor of %d.\n",b,a);
        }else{
            printf("LCA of %d and %d is %d.\n",a,b,ans);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值