1151 LCA in a Binary Tree (30 分)【最小公共祖先】

41 篇文章 0 订阅
7 篇文章 0 订阅

1151 LCA in a Binary Tree (30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

题意:找出最小的公共祖先,不存在的节点输出不存在。

解题思路:可以将题目转化成甲级题目1143。我们知道二叉搜索树的公共祖先是在中间,所以我们也可以弄成二叉搜索树,就是用下标处理。二叉搜索树的中序是按照从小到大排序,所以我们将二叉搜索树的下标从1开始标记到n,然后将pre也弄成下标,下标这样处理就基本上可以按照1143做了,具体的见代码。(不过这里只有29分,还差一分,在第三个测试点出现段错误,希望看到的朋友帮忙指点一下) 

#include<iostream>
#include<cstdio>
#include<vector>
#include<map>
using namespace std;

map<int,bool>mapp;

int main(void)
{
	int m,n;
	int in[10010];
	scanf("%d%d",&m,&n);
	vector<int>invalue(n+1),prevalue(n+1),pre(n+1);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&invalue[i]);
		in[invalue[i]]=i;
	}
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&prevalue[i]);
		mapp[prevalue[i]]=true;
		pre[i]=in[prevalue[i]];
	}
	int a;
	for(int i=0;i<m;i++)
	{
		int u,v,u1,v1;
		scanf("%d %d",&u,&v);
		u1=in[u],v1=in[v];
		for(int j=1;j<=n;j++)
		{
			a=pre[j];
			if(a>=u1&&a<=v1||a>=v1&&a<=u1) break;
		}
		if(mapp[u]==false&&mapp[v]==false)
		printf("ERROR: %d and %d are not found.\n",u,v);
		else if(mapp[u]==true&&mapp[v]==false)
		printf("ERROR: %d is not found.\n",v);
		else if(mapp[u]==false&&mapp[v]==true)
		printf("ERROR: %d is not found.\n",u);
		else if(a==u1||a==v1)
		printf("%d is an ancestor of %d.\n",invalue[a],a==u1?v:u);
		else  printf("LCA of %d and %d is %d.\n",u,v,invalue[a]);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 4
    评论
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值