【剑指紫金港】1108 Finding Average(sscanf和sprintf)

A 1108 Finding Average

题目链接

Problem Description

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

AC代码

#include<bits/stdc++.h>
using namespace std;
const int maxn = 255;
int n,cnt=0;
char str[maxn],magic[maxn];
double sum=0.0,temp=0.0;

int main(){
    scanf("%d",&n);
    while(n--){
        scanf("%s",str);
        sscanf(str,"%lf",&temp);
        sprintf(magic,"%.2f",temp);
        bool flag=true;
        for(int i=0,len=strlen(str);i<len;i++){
            if(str[i]!=magic[i]){
                flag=false;
                break;
            }
        }
        if(!flag || temp<-1000 || temp>1000){
            printf("ERROR: %s is not a legal number\n",str);
            continue;
        }else{
            sum+=temp;
            cnt++;
        }
    }
    if(cnt==0){
        printf("The average of 0 numbers is Undefined");
    }else if(cnt==1){
        printf("The average of 1 number is %.2f",sum);
    }else{
        printf("The average of %d numbers is %.2f",cnt,sum/cnt);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值