【剑指紫金港】1136 A Delayed Palindrome 字符串骚操作

A 1136 A Delayed Palindrome

题目链接

Problem Description

Consider a positive integer N written in standard notation with k+1 digits a​i​​ as a​k​​ ⋯a​1​​ a​0​​ with 0≤a​i​​ <10 for all i and a​k​​ >0. Then N is palindromic if and only if a​i​​ =a​k−i​​ for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number )

Given any positive integer, you are supposed to find its paired palindromic number.

Input

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C

where Ais the original number, Bis the reversed A, and Cis their sum. Astarts being the input number, and this process ends until Cbecomes a palindromic number – in this case we print in the last line C is a palindromic number.; or if a palindromic number cannot be found in 10 iterations, print Not found in 10 iterations.instead.

Sample Input 1:

97152

Sample Output 1:

97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.

Sample Input 2:

196

Sample Output 2:

196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.

题目大意

英文题目太长了。。看样例也能看懂,将一个数倒置然后和原来的数相加,找到第一个回文数。

解题思路

善用reverse函数。

AC代码

#include<bits/stdc++.h>
using namespace std;
bool check(string s){
    int k=0,len=s.size()-1;
    while(k<len-k){
        if(s[k]!=s[len-k]) return false;
        k++;
    }
    return true;
}
string add(string x,string y){
    string ans="";
    int temp=0,sum;
    for(int i=x.size()-1;i>=0;i--){
        sum=(x[i]-'0')+(y[i]-'0')+temp;
        ans+=(sum%10)+'0';
        temp=sum/10;
    }
    if(temp==1) ans+='1';
    reverse(ans.begin(),ans.end());
    return ans;
}
int main(){
    string a,b,c;
    int i;
    cin>>c;
    if(check(c)){
        printf("%s is a palindromic number.",c.c_str());
        return 0;
    }
    for(i=0;i<10;i++){
        a=c,b=c;
        reverse(b.begin(),b.end());
        c=add(a,b);
        printf("%s + %s = %s\n",a.c_str(),b.c_str(),c.c_str());
        if(check(c)) break;
    }
    if(i==10){
        printf("Not found in 10 iterations.");
    }else{
        printf("%s is a palindromic number.",c.c_str());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

征服所有不服

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值