矩阵链乘.cpp

Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Sincematrix multiplicationisassociative, theorderin whichmultiplicationsareperformedis arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose. For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C). The first one takes 15000 elementary multiplications, but the second one only 3500. Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy. Input Input consists of two parts: a list of matrices and a list of expressions. The first line of the input file contains one integer n (1 ≤ n ≤ 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix. The second part of the input file strictly adheres to the following syntax (given in EBNF): SecondPart = Line { Line } <EOF> Line = Expression <CR> Expression = Matrix | "(" Expression Expression ")" Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z" Output Foreachexpressionfoundinthesecondpartoftheinputfile,printonelinecontainingtheword‘error’ if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses. 

Sample Input

9

A 50 10

B 10 20

C 20 5

D 30 35

E 35 15

F 15 5

G 5 10

H 10 20

I 20 25

A

B

C

(AA)

(AB)

(AC)

(A(BC))

((AB)C)

(((((DE)F)G)H)I)

(D(E(F(G(HI)))))

((D(EF))((GH)I))

Sample Output

0

0

0

error

10000

error

3500

15000

40500

47500

15125

思路:用栈的思维把括号进站中一步步判断

#include<iostream>
#include<stack>
#include<queue>
#include<string.h>
#include<algorithm>
#include<stdlib.h>
#include<cstdio>
using namespace std;
struct student
{
	int l,r;
	student(){}
	student (int ll,int rr):l(ll),r(rr){}	
}d[1000];
char a[10000];stack<student>A;
int main()
{
	int n;char p;
	scanf("%d",&n);
	for(int i = 0;i < n ;i++)
	{
		getchar();
		cin>>p;
		cin>>d[i].l;
		cin>>d[i].r;
	}
	while(~scanf("%s",&a))
	{
		bool flag = 0;
		int d1 = strlen(a);long long sum=0;
		for(int i = 0;i < d1;i++)
		{
			if('A' <= a[i] && a[i] <= 'Z')
			{
				A.push(d[a[i]-'A']); 
			} 
			else if(a[i] == ')'){
				student t2 = A.top();A.pop();
				student t1 = A.top();A.pop();
				if( t1.r !=  t2.l)
				{
					flag = 1;break;
				}
				else{
					sum += t1.l*t1.r*t2.r;
					A.push(student(t1.l,t2.r));
				}	
			}
		}
		if(flag == 1)
		{
			printf("error\n");
		}
		else{
			printf("%lld\n",sum);
		}
		while(!A.empty())
		{
			A.pop();
		}
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

-lyslyslys

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值