Wormholes-spfa模板题

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

#include<iostream>
#include<vector>
#include<cstring>
#include<cstdio> 
#include<queue>
using namespace std;
const int MAXN = 1e5+5;
const int INF = 0x3f3f3f3f;
struct Edge
{
	int from,to,dist;
	Edge(int u,int v,int w):from(u),to(v),dist(w){	}
};
struct SPFA
{
	int n,m;
	vector<Edge>edges;
	vector<int>G[MAXN];
	bool vis[MAXN];
	int d[MAXN];
	int p[MAXN];
	int cnt[MAXN];
	void init(int n)
	{
		this->n = n;
		edges.clear();
		for(int i=0;i<=n;i++)G[i].clear();
	} 
	void AddEdge(int from,int to,int dist)
	{
		edges.push_back(Edge(from,to,dist));
		m = edges.size();
		G[from].push_back(m-1);
	}
	bool spfa(int s)
	{
		for(int i=0;i<=n;i++)d[i] = INF;
		memset(vis,0,sizeof(vis));
		memset(cnt,0,sizeof(cnt));
		d[s] = 0; vis[s] = true;
		queue<int>Q;
		Q.push(s);
		while(!Q.empty())
		{
			int u = Q.front();
			Q.pop();
			vis[u] = false;
			for(int i=0;i<G[u].size();i++)
			{
				Edge &e = edges[G[u][i]];
				if(d[u] < INF && d[e.to] > d[u] +e.dist)
				{
					d[e.to] = d[u] + e.dist;
					p[e.to] = G[u][i];
					if(!vis[e.to])
					{
						Q.push(e.to);vis[e.to] = true;
						if(++cnt[e.to] > n)return false; 
					}
				 } 
			}
		}
		return true;
	}
	
}solve;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,m,w;
		scanf("%d%d%d",&n,&m,&w);
		solve.init(n);
		while(m--)
		{
			int u,v,t;
			scanf("%d%d%d",&u,&v,&t);
			solve.AddEdge(u,v,t);
			solve.AddEdge(v,u,t);
		}
		while(w--)
		{
			int u,v,t;
			scanf("%d%d%d",&u,&v,&t);
			solve.AddEdge(u,v,-t);
		}
		if(!solve.spfa(1))printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

-lyslyslys

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值