It's All In The Mind

Problem Description

Professor Zhang has a number sequence a1,a2,...,an. However, the sequence is not complete and some elements are missing. Fortunately, Professor Zhang remembers some properties of the sequence:

1. For every i∈{1,2,...,n}, 0≤ai≤100.
2. The sequence is non-increasing, i.e. a1≥a2≥...≥an.
3. The sum of all elements in the sequence is not zero.

Professor Zhang wants to know the maximum value of a1+a2∑ni=1ai among all the possible sequences.

 

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first contains two integers n and m (2≤n≤100,0≤m≤n) -- the length of the sequence and the number of known elements.

In the next m lines, each contains two integers xi and yi (1≤xi≤n,0≤yi≤100,xi<xi+1,yi≥yi+1), indicating that axi=yi.

 

 

Output

For each test case, output the answer as an irreducible fraction "p/q", where p, q are integers, q>0.

 

 

Sample Input

 

2 2 0 3 1 3 1

 

 

Sample Output

 

1/1 200/201

 

 

Author

zimpha

 

 

Source

2016 Multi-University Training Contest 2

 

 

Recommend

wange2014

汉语题目:

问题描述

张教授有一个数字序列a1,a2,…,an。但是,序列不完整,一些元素丢失。幸运的是,张教授记得序列的一些性质:

1。每i∈1,2,…,n,0≤ai≤100。

2。序列不递增,即a1≥a2≥…≥an。

三。序列中所有元素的和不是零。

张教授想知道所有可能的序列中a1+a2∑ni=1ai的最大值。

γ

γ

输入

有多个测试用例。输入的第一行包含一个整数t,指示测试用例的数量。对于每个测试用例:

第一个包含两个整数n和m(2≤n≤100,0≤m≤n)——序列的长度和已知元素的数量。

在下一条M线中,每一个包含两个整数,即Xi和Yi(1个<Xi<n,0个<Yi<100,Xi<Xi+1,Yi±Yi+1),表示Axi=Yi。

γ

γ

产量

对于每个测试用例,输出不可约分数“p/q”,其中p,q为整数,q>0。

γ

γ

样本输入


γ

2 2 0 0 3 1 3 1

γ

γ

样本输出


γ

1/1 200/201

γ

γ

作者

津马

γ

γ

来源

2016年多所大学培训竞赛2

γ

γ

题意:求前两项最大后面最小的组合成的数用分数表示

用一个数存最大一个存可以的最小的已经定的不改只更新最大最小值

代码如下:

#include<iostream>
#include<algorithm>
using namespace std;
int a[1000009];
int main()
{
	int t;int n,m;
	while(~scanf("%d",&t))
	{
		while(t--)
		{
			scanf("%d%d",&n,&m);int sum1=0,sum2=0;
			for(int i=0;i<=101;i++)
			{
				a[i] = -1;//把数组初始化成-1
			}
			int x,y;
			for(int i=1;i<=m;++i)
			{
				scanf("%d%d",&x,&y);
				a[x] = y;//已经赋值的数
			}
			int max1=0;
			for(int i=n;i>2;--i)
			{
				if(a[i]==-1)
				{
					a[i] = max1;//未赋值的变成可以的最大值
				}
				else{
				max1=a[i];	//更新最大
				}
			}
			int uu=100;
			for(int i=1;i<=2;++i)
			{
				if(a[i] == -1)
				{
					a[i] = uu;//未赋值的变成可以的最小值
				 } 
				 else{
				 	uu=a[i];更新最小
				 }
			}
			for(int i=1;i<=2;++i)
			{
				sum1+=a[i];
			}
			 for(int i=1;i<=n;++i)
			{
				sum2+=a[i];
			} 
			 int gg =__gcd(sum1,sum2);
			 sum1 = sum1/gg;//用gcd约分
			 sum2 = sum2/gg;
			 printf("%d/%d\n",sum1,sum2);	
		}
		
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

-lyslyslys

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值