Game-hdu6312

Alice and Bob are playing a game. 
The game is played on a set of positive integers from 1 to n. 
In one step, the player can choose a positive integer from the set, and erase all of its divisors from the set. If a divisor doesn't exist it will be ignored. 
Alice and Bob choose in turn, the one who cannot choose (current set is empty) loses. 
Alice goes first, she wanna know whether she can win. Please judge by outputing 'Yes' or 'No'.

Input

There might be multiple test cases, no more than 10. You need to read till the end of input. 
For each test case, a line containing an integer n. (1≤n≤5001≤n≤500) 

Output

A line for each test case, 'Yes' or 'No'. 

Sample Input

1

Sample Output

Yes

直接取1把所有项消掉

#include<iostream>
#include<cstring>
#include<cstdio> 
using namespace std;
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		printf("Yes\n");
	}
	
	return 0;
} 	

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

-lyslyslys

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值