POJ 2528线段树区间改值+染色问题+区间离散化

题目描述

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.
They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters’ size, their place and order of placement on the electoral wall.

输入

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,… , ri.

输出

For each input data set print the number of visible posters after all the posters are placed.
The picture below illustrates the case of the sample input.
在这里插入图片描述

样例输入

1
5
1 4
2 6
8 10
3 4
7 10

样例输出

4

思路

一道基础的区间染色问题,只是区间的值非常大,所以需要进行离散化操作。
对数据进行离散化,由于是一段进行连续化,故两个点之间的差值大于1时,应该在中间再加入一个点。
比如 【1, 10】 【1,4】【5, 10】 离散化后是【1,4】【1,2】【3, 4】
然而 【1, 10】 【1,4】【6, 10】离散化后也是【1,4】【1,2】【3, 4】,然而这种情况看到的数量应该是3
所以我们应该在4 和 6 中间添加一个点5,这样进行区间修改的时候就不会出错。
tree[]初始值为0表示没有颜色,-1表示有多种颜色,每张报纸都有自己的一个单独的颜色。然后套用染色模板就可以求出最后的结果了。
染色模板

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
const int maxn=10005;
int tree[maxn<<4],lazy[maxn<<4];
int A[maxn<<2],chl[maxn],chr[maxn];
int N;
bool vis[maxn];
int ans=0;
void init(){
	memset(tree,0,sizeof(tree));
	memset(lazy,0,sizeof(lazy));
	memset(vis,0,sizeof(vis));
	ans=0;
}
void pushdown(int id){
	if(lazy[id]){
		tree[id<<1]=lazy[id];
		tree[id<<1|1]=lazy[id];
		lazy[id<<1|1]=lazy[id];
		lazy[id<<1]=lazy[id];
		lazy[id]=0;
	}
}
void update(int id,int l,int r,int a,int b,int c){
	if(a<=l&&r<=b){
		tree[id]=c;
		lazy[id]=c;
		return;
	}
	pushdown(id);
	int mid=(l+r)>>1;
	if(a<=mid)update(id<<1,l,mid,a,b,c);
	if(b>mid)update(id<<1|1,mid+1,r,a,b,c);
	if(tree[id<<1]==tree[id<<1|1]){
		tree[id]=tree[id<<1];
	}
	else{
		tree[id]=-1;
	}
}
void query(int id,int l,int r,int a,int b){
	if(a<=l&&r<=b){
		if(tree[id]==0)return;
		if(tree[id]==-1){
			int mid=(l+r)>>1;
			query(id<<1,l,mid,a,b);
			query(id<<1|1,mid+1,r,a,b);
		}
		else{
			if(vis[tree[id]]==0){
				ans++;
				vis[tree[id]]=1;
			}
		}
		return;
	}
	pushdown(id);
	int mid=(l+r)>>1;
	if(a<=mid)query(id<<1,l,mid,a,b);
	if(b>mid)query(id<<1|1,mid+1,r,a,b);
}  
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&N);
		init();
		int cnt=0;
		for(int i=1;i<=N;i++){
			scanf("%d%d",&chl[i],&chr[i]);
			A[++cnt]=chl[i];
			A[++cnt]=chr[i];
		}
		sort(A+1,A+cnt+1);
		int t=unique(A+1,A+cnt+1)-A-1;
		int m=t;
		for(int i=2;i<=t;i++){
			if(A[i]-A[i-1]>1){
				A[++m]=A[i-1]+1;//对于前后之间的距离大于1的点再在中间加一个点 
			}
		}
		cnt=m;
		sort(A+1,A+cnt+1);
		for(int i=1;i<=N;i++){
			int x=lower_bound(A+1,A+cnt+1,chl[i])-A;//在离散化后中的点找到左端点 
			int y=lower_bound(A+1,A+cnt+1,chr[i])-A;//在离散化后的点找到右端点 
			update(1,1,cnt,x,y,i);//然后对这个区间进行颜色更新 
		}
		query(1,1,cnt,1,cnt);
		cout << ans << endl;
	}
	return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值