HDU 3974 DFS序+区间染色+单点查询

Problem Description

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody’s boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.
The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.
Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input

The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.
For each test case:
The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.
The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).
The next line contains an integer M (M ≤ 50,000).
The following M lines each contain a message which is either
“C x” which means an inquiry for the current task of employee x
or
"T x y"which means the company assign task y to employee x.
(1<=x<=N,0<=y<=10^9)

Output

For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

Sample Input

1
5
4 3
3 2
1 3
5 2
5
C 3
T 2 1
C 3
T 3 2
C 3

Sample Output

Case #1:
-1
1
2

思路

刚开始想了很久到底要维护一个什么样的区间,然后怎么处理雇主和雇员的关系。后面查了下资料才知道利用DFS的栈的方式,将一个节点的进入栈时间和出栈时间保存起来,入栈时间最早那就代表出栈时间最晚,其实就代表了一个区间,在这个区间范围就是总的区间范围,之后我们维护这个区间就行了。查询就用单点查询,用该点的入栈时间或者出栈时间进行查询就可以了。

AC 代码

#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
using namespace std;
const int maxn=50005;
int tree[maxn<<4],dd[maxn];
vector <int> g[maxn];
int lf[maxn],rt[maxn];
int N;
int cnt=0;
void dfs(int u){
	lf[u]=++cnt;
	for(int i=0;i<g[u].size();i++){
		dfs(g[u][i]);
	}
	rt[u]=++cnt;
}
void pushdown(int id){
	if(tree[id]!=-1){
		tree[id<<1]=tree[id<<1|1]=tree[id];
		tree[id]=-1;
	}
}
void update(int id,int l,int r,int a,int b,int c){
	if(a<=l&&r<=b){
		tree[id]=c;
		return;
	}
	pushdown(id);
	int mid=(l+r)>>1;
	if(a<=mid)update(id<<1,l,mid,a,b,c);
	if(b>mid)update(id<<1|1,mid+1,r,a,b,c);
}
int query(int id,int l,int r,int x){
	if(l==r){
		return tree[id];
	}
	pushdown(id);
	int mid=(l+r)>>1;
	if(x<=mid)return query(id<<1,l,mid,x);
	else return query(id<<1|1,mid+1,r,x);
}
int main(){
	int T;
	scanf("%d",&T);
	for(int k=1;k<=T;k++){
		printf("Case #%d:\n",k);
		scanf("%d",&N);
		int u,v;
		cnt=0;
		memset(dd,0,sizeof(dd));
		memset(tree,-1,sizeof(tree));
		for(int i=0;i<=N;i++){
			g[i].clear();
		}
		for(int i=1;i<=N-1;i++){
			scanf("%d%d",&u,&v);
			dd[u]++;//用于记录每个节点的入度,后面用于判断BOSS
			g[v].push_back(u);
		}
		int root;
		for(int i=1;i<=N;i++){
			if(!dd[i]){
				root=i;//寻找BOSS
				break;
			}
		}
		dfs(root);//从BOSS开始进行DFS序的绘制
		int M;
		scanf("%d",&M);
        while(M--)
        {
            char op[3];
            int x,y;
            scanf("%s",op);
            if(op[0]=='C')
            {
                scanf("%d",&x);
                printf("%d\n",query(1,1,2*N,rt[x]));
            }
            else
            {
                scanf("%d %d",&x,&y);
                update(1,1,2*N,lf[x],rt[x],y);
            }
        }
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值