POJ 3009 DFS回溯

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.

在这里插入图片描述

Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:
The stone hits a block (Fig. 2(b), ©).
The stone stops at the square next to the block it hit.
The block disappears.
The stone gets out of the board.
The game ends in failure.
The stone reaches the goal square.
The stone stops there and the game ends in success.
You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.
在这里插入图片描述
Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).

在这里插入图片描述

Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position
The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

题意

大概意思是,在一个星球上,一群人玩冰壶游戏,冰壶只能沿着一个方向前进(对角线不行),并且只有遇到block才能停下来,停下来后block就被击碎了(变为能走的路),对于当前点位旁边如果有block则不能发球。最后求从起点到重点最短的击球次数,要求在10次以内完成。

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int a[25][25],sx,sy;
int ans=0x3f3f3f3f;
int dx[]={0,-1,0,1};
int dy[]={1,0,-1,0};
	int row,col;
bool check(int x,int y){
	if(x<=0||y<=0||x>row||y>col)return false;
	return true;
}
void dfs(int cnt,int x,int y){
	if(cnt>=10)return;
	if(ans<cnt)return;//小小的剪枝 
	for(int i=0;i<4;i++){
		int tempX=x+dx[i];
		int tempY=y+dy[i];
		if(check(tempX,tempY)&&a[tempX][tempY]==1)continue;//如果冰壶旁边就有block的话就不能走。 
		while(check(tempX,tempY)){
			if(a[tempX][tempY]==1){
				int nx=tempX-dx[i];
				int ny=tempY-dy[i];
				a[tempX][tempY]=0;//冰壶被击碎 
				dfs(cnt+1,nx,ny);
				a[tempX][tempY]=1;//回溯 
				break;
			}
			else if(a[tempX][tempY]==3){
				ans=min(ans,cnt+1);
				break;
			}
			tempX+=dx[i];
			tempY+=dy[i];
		}
	}
}
int main(){
	while(scanf("%d%d",&col,&row),row){
		for(int i=1;i<=row;i++){
			for(int j=1;j<=col;j++){
				cin >> a[i][j];
				if(a[i][j]==2){
					sx=i;
					sy=j;
				}
			}
		}
		ans=0x3f3f3f3f;
		dfs(0,sx,sy);
		if(ans!=0x3f3f3f3f&&ans<=10)
		cout << ans << endl;
		else cout << -1 << endl; 
	}
	return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值