SDUT-Extended Traffic(spfa判断负环)

Dhaka city is getting crowded and noisy day by day. Certain roads always remain blocked in congestion. In order to convince people avoid shortest routes, and hence the crowded roads, to reach destination, the city authority has made a new plan. Each junction of the city is marked with a positive integer (≤ 20) denoting the busyness of the junction. Whenever someone goes from one junction (the source junction) to another (the destination junction), the city authority gets the amount (busyness of destination - busyness of source)3 (that means the cube of the difference) from the traveler. The authority has appointed you to find out the minimum total amount that can be earned when someone intelligent goes from a certain junction (the zero point) to several others.
Input

Input starts with an integer T (≤ 50), denoting the number of test cases.

Each case contains a blank line and an integer n (1 < n ≤ 200) denoting the number of junctions. The next line contains n integers denoting the busyness of the junctions from 1 to n respectively. The next line contains an integer m, the number of roads in the city. Each of the next m lines (one for each road) contains two junction-numbers (source, destination) that the corresponding road connects (all roads are unidirectional). The next line contains the integer q, the number of queries. The next q lines each contain a destination junction-number. There can be at most one direct road from a junction to another junction.
Output

For each case, print the case number in a single line. Then print q lines, one for each query, each containing the minimum total earning when one travels from junction 1 (the zero point) to the given junction. However, for the queries that gives total earning less than 3, or if the destination is not reachable from the zero point, then print a ‘?’.
Sample Input

2

 

5

6 7 8 9 10

6

1 2

2 3

3 4

1 5

5 4

4 5

2

4

5

 

2

10 10

1

1 2

1

2

Sample Output

Case 1:

3

4

Case 2:

?

题目大意
有n条路给出各个道路之间的拥挤度
时间是拥挤度的差值的3次方 所有就会存在差值为负值 然后负权环 就会一直循环时间减少
思路
用spfa然后开一个数组记录道路号进入栈的次数如果超过n次就是负权边哦

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <queue>
#define inf 0x3f3f3f3f

using namespace std;

int dis[1000005];
int head[1000005];
int vir[1000005];
int book[300];
int p[300];
int n, m;

struct node
{
    int from, to, w, next;
} e[1000005];

void spfa(int b)
{
    memset(vir, 0, sizeof(vir));
    memset(dis, inf, sizeof(dis));
    queue<int> Q;
    dis[b] = 0;
    vir[b] = 1;
    Q.push(b);
    while(!Q.empty())
    {
        int u = Q.front();
        Q.pop();
        vir[u] = 0;
        for(int i = head[u]; i!=-1; i = e[i].next)
        {
            if(dis[e[i].to]>dis[u] + e[i].w)
            {
                dis[e[i].to] = dis[u] + e[i].w;
                if(vir[e[i].to]==0&&book[e[i].to]<=n)
                {
                    vir[e[i].to] = 1;
                    Q.push(e[i].to);
                    book[e[i].to]++;
                }
            }
        }
    }
}
int main()
{
    int t;
    int flag = 0;
    scanf("%d", &t);
    while(t--)
    {
        flag++;
        memset(book, 0, sizeof(book));
        memset(head, -1, sizeof(head));
        scanf("%d", &n);
        for(int i=1; i<=n; i++)
        {
            scanf("%d", &p[i]);
        }
        int ans = 0;
        int m, u, v;
        scanf("%d", &m);
        for(int i =1; i<=m; i++)
        {
            scanf("%d %d", &u, &v);
            e[ans].from = u;
            e[ans].to = v;
            e[ans].w = (p[v]-p[u])*(p[v]-p[u])*(p[v]-p[u]);
            e[ans].next = head[u];
            head[u] = ans++;
        }
        spfa(1);
        int nn, End;
        scanf("%d", &nn);
        printf("Case %d:\n", flag);
        for(int i=1; i<=nn; i++)
        {
            scanf("%d", &End);
            if(dis[End]>=3&&dis[End]!=inf&&book[End]<=n)
            {
                printf("%d\n", dis[End]);
            }
            else printf("?\n");
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值