C - A Simple Problem with Integers(线段树区间更新)

7 篇文章 0 订阅
4 篇文章 0 订阅

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

You need to answer all Q commands in order. One answer in a line.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<bitset>
#include<cassert>
#include<cctype>
#include<cmath>
#include<cstdlib>
#include<ctime>
#include<deque>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>
#define lt k << 1
#define rt k << 1 | 1
using namespace std;
const double pi = acos(-1.0);
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1e6 + 50;
ll a[maxn], n, q;
struct node
{
    ll l, r;
    ll sum, lazy;
} tree[maxn * 4];
void build(ll left, ll right, ll num)
{
    tree[num].l = left;
    tree[num].r = right;
    tree[num].lazy = 0;
    if(left == right)
    {
        tree[num].sum = a[left];
        return ;
    }
    ll mid = (left + right)/2;
    build(left, mid, num * 2);
    build(mid + 1, right, num *2 + 1);
    tree[num].sum = tree[num *2].sum + tree[num * 2 + 1].sum;
}
void pushdown(ll n)
{
    tree[n * 2].sum += tree[n].lazy * (tree[n * 2].r - tree[n * 2].l + 1);
    tree[n * 2 + 1].sum += tree[n].lazy * (tree[n * 2 + 1].r - tree[n * 2 +1].l + 1);
    tree[n * 2].lazy += tree[n].lazy;
    tree[n * 2 + 1].lazy += tree[n].lazy;
    tree[n].lazy = 0;
}
ll query(ll x, ll y, ll num)
{
    if(tree[num].lazy) pushdown(num);
    if(x <= tree[num].l && tree[num].r <= y) return tree[num].sum;
    ll mid = (tree[num].l + tree[num].r)/2;
    if(mid >= y)
    {
        return query(x, y, num * 2);
    }
    else if(mid < x)
    {
        return query(x, y, num * 2 + 1);
    }
    else
    {
        return query(x, mid, num * 2) + query(mid + 1, y, num * 2 + 1);
    }
}

void add_qu(ll x, ll y, ll w, ll num)
{

    if(x == tree[num].l && tree[num].r == y)
    {
        tree[num].sum += (tree[num].r - tree[num].l + 1)*w;
        tree[num].lazy += w;
        return ;
    }
    if(tree[num].lazy) pushdown(num);
    ll mid = (tree[num].l + tree[num].r)/2;
    if(mid >= y) add_qu(x, y, w, num * 2);
    else if(mid < x) add_qu(x, y, w, num * 2 + 1);
    else
    {
        add_qu(x, mid, w, num * 2);
        add_qu(mid + 1, y, w, num*2 + 1);
    }
    tree[num].sum = tree[num*2].sum + tree[num * 2 + 1].sum;
}
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    cin >> n >> q;
    for(ll i=1; i<=n; i++)
    {
        cin >> a[i];
    }
    build(1, n, 1);
    while(q--)
    {
        char ch;
        ll x, y, w;
        cin >> ch;
        if(ch == 'Q')
        {
            cin >> x >> y;
            cout << query(x, y, 1) << endl;
        }
        else if(ch == 'C')
        {
            cin >> x >> y >> w;
            add_qu(x, y, w, 1);
        }
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值