1053 Path of Equal Weight (30 分)(树的静态写法的应用——求路径上的权值)

1053 Path of Equal Weight (30 分)

Given a non-empty tree with root RRR, and with weight WiW_iW​i​​ assigned to each tree node TiT_iT​i​​. The weight of a path from RRR to LLL is defined to be the sum of the weights of all the nodes along the path from RRR to any leaf node LLL.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤1000 < N \le 1000<N≤100, the number of nodes in a tree, MMM (<N< N<N), the number of non-leaf nodes, and 0<S<2300 < S < 2^{30}0<S<2​30​​, the given weight number. The next line contains NNN positive numbers where WiW_iW​i​​ (<1000<1000<1000) corresponds to the tree node TiT_iT​i​​. Then MMM lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1,A2,⋯,An}\{A_1, A_2, \cdots , A_n\}{A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B1,B2,⋯,Bm}\{B_1, B_2, \cdots , B_m\}{B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m}1 \le k < min\{n, m\}1≤k<min{n,m} such that Ai=BiA_i = B_iA​i​​=B​i​​ for i=1,⋯,ki=1, \cdots , ki=1,⋯,k, and Ak+1>Bk+1A_{k+1} > B_{k+1}A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题意为树根到叶子结点的权值和是否等于给定值,若是,则输出路径上的权值。采用先根序遍历的算法,计算到叶子结点的权值。若未到达叶子结点时,权值和已大于给定值,则直接返回。若等于给定值,则判断是否是叶子结点,若是,则输出路径数组path中的结点的权值,否则返回。

参考代码如下:

#include <cstdio> 
#include <vector>
#include <algorithm>
using namespace std;
const int maxn=110;
struct node{
	int weight;
	vector<int> child;
}Node[maxn];
bool cmp(int a,int b)
{
	return Node[a].weight>Node[b].weight;
 } 
int n,m,s;
int path[maxn];

//当前访问结点为index,numNode为当前路径path上的结点个数
//sum为当前结点的权和
void DFS(int index,int numNode,int sum)
{
	if(sum>s) //当前和sum超过s,直接返回 
		return;
	if(sum==s)
	{
		if(Node[index].child.size()!=0) //还没到叶子结点,直接返回 
			return ;
		//到达叶子结点,此时path中存放了一条完整路径,输出它
		for(int i=0;i<numNode;++i)
		{
			printf("%d",Node[path[i]].weight);
			if(i<numNode-1)
				printf(" ");
			else
				printf("\n");
		}
		return ;
	}
	for(int i=0;i<Node[index].child.size();++i) //枚举所有子结点 
	{
		int child=Node[index].child[i];//结点index的第i的子结点编号
		path[numNode]=child; //将child加到路径path末尾
		DFS(child,numNode+1,sum+Node[child].weight);//递归进入下一层 
	} 
}

int main()
{
	scanf("%d%d%d",&n,&m,&s);
	for(int i=0;i<n;++i)
	{
		scanf("%d",&Node[i].weight);
	}
	int id,k,child;
	for(int i=0;i<m;++i)
	{
		scanf("%d%d",&id,&k);//结点编号,孩子个数
		for(int j=0;j<k;++j)
		{
			scanf("%d",&child);
			Node[id].child.push_back(child); //child为结点id 的孩子 
		 } 
		sort(Node[id].child.begin(),Node[id].child.end(),cmp);//排序 
	}
	path[0]=0;//路径的第一个结点设置为0号结点 
	DFS(0,1,Node[0].weight);
	return 0; 
 } 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值