PAT甲级1146 Topological Order (25 分)

1146 Topological Order (25 分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.
Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4
题目大意就是让你判断几个序列是否为拓扑排序,在输入数据时统计每个点的度,在判断时每次去除一个度,只有当每次的点的度都为0时才为拓扑排序,否则不是

代码:
#include<bits/stdc++.h>

using namespace std;

const int maxn = 1e4+5;
vector<int>vec[maxn];
vector<int>vt; 
int in[maxn];
int n,m;

int main()
{
	cin >> n >> m;
	for(int i = 0 ; i < m ; i++)
	{
		int x,y;
		cin >> x >> y;
		vec[x].push_back(y);
		in[y]++;
	}
	int q;
	cin >> q;
	for(int i = 0 ; i < q ; i++)
	{
		int judge = 1;
		vector<int>v(in,in+n+1);
		for(int k = 0 ; k < n ; k++)
		{
			int x;
			cin >> x;
			if(v[x])
				judge = 0;
			for(int j = 0 ; j < vec[x].size() ; j++)
				v[vec[x][j]]--;
		}
		if(judge == 1)
			continue;
		vt.push_back(i);
	}
	for(int i = 0 ; i < vt.size() ; i++)
	{
		cout << vt[i];
		if(i != vt.size() - 1)
			cout << " ";
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柠檬ya

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值