A-A计划【暑假专二 搜索进阶】

Description

可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后,而今,不幸的她再一次面临生命的考验。魔王已经发出消息说将在T时刻吃掉公主,因为他听信谣言说吃公主的肉也能长生不老。年迈的国王正是心急如焚,告招天下勇士来拯救公主。不过公主早已习以为常,她深信智勇的骑士LJ肯定能将她救出。
现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示。骑士们一进入时空传输机就会被转到另一层的相对位置,但如果被转到的位置是墙的话,那骑士们就会被撞死。骑士们在一层中只能前后左右移动,每移动一格花1时刻。层间的移动只能通过时空传输机,且不需要任何时间。

Input

输入的第一行C表示共有C个测试数据,每个测试数据的前一行有三个整数N,M,T。 N,M迷宫的大小NM(1 <= N,M <=10)。T如上所意。接下去的前NM表示迷宫的第一层的布置情况,后N*M表示迷宫第二层的布置情况。

Output

如果骑士们能够在T时刻能找到公主就输出“YES”,否则输出“NO”。

Sample Input

1
5 5 14
S*#*.
.#…

****.
…#.

.P
#.

**
.
*.#…

Sample Output

YES

Code

//bfs
#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
int n,m,t;
#define CHECK(x,y)(x<n&&x>=0&&y<m&&y>=0)
char maze[5][20][20];
struct node{
    int x,y,l;  //行,列,层
    int step;
};

void bfs(){
    queue<node>q;
    node start,next;
    start.x=0;
    start.y=0;
    start.l=0;
    start.step=0;
    maze[start.l][start.x][start.y]='*';
    q.push(start);
    while(!q.empty()){
        start=q.front();
        q.pop();
        for(int i=0;i<4;i++){
            next.x=start.x+dir[i][0];
            next.y=start.y+dir[i][1];
            next.l=start.l;
            if(CHECK(next.x,next.y)&&maze[next.l][next.x][next.y]=='*') continue;
            if(CHECK(next.x,next.y)&&maze[next.l][next.x][next.y]=='.'){
                maze[next.l][next.x][next.y]='*';
                next.step=start.step+1;
                q.push(next);
            }
            if(CHECK(next.x,next.y)&&maze[next.l][next.x][next.y]=='P'){
                next.step=start.step+1;
                if(next.step<=t) cout<<"YES"<<endl;
                else cout<<"NO"<<endl;
                return;
            }
            if(CHECK(next.x,next.y)&&maze[next.l][next.x][next.y]=='#'){
                next.l==0?next.l=1:next.l=0;    //时空传输机的实现
                if(maze[next.l][next.x][next.y]=='*'){
                    maze[0][next.x][next.y]='*';
                    maze[1][next.x][next.y]='*';
                }
                if(maze[next.l][next.x][next.y]=='.'){
                    maze[next.l][next.x][next.y]='*';
                    next.step=start.step+1;
                    q.push(next);
                }
                if(maze[next.l][next.x][next.y]=='P'){
                    next.step=start.step+1;
                    if(next.step<=t) cout<<"YES"<<endl;
                    else cout<<"NO"<<endl;
                    return;
                }
            }
        }
    }
    cout<<"NO"<<endl;
    return;
}

int main(){
    int C;
    cin>>C;
    while(C--){
        cin>>n>>m>>t;
        for(int i=0;i<2;i++){
            for(int j=0;j<n;j++){
                scanf("%s",maze[i][j]);
            }
            getchar();
        }
        bfs();
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值