HDU 6441 Find Integer (费马大定理)

Description:

people in USSS love math very much, and there is a famous math problem
give you two integers n,a,you are required to find 2 2 2 integers b , c b,c b,c such that a n + b n = c n a_{n}+b_{n}=c_{n} an+bn=cn.

Input

one line contains one integer T ; ( 1 ≤ T ≤ 1000000 ) T;(1≤T≤1000000) T;(1T1000000)

next T lines contains two integers n , a ; ( 0 ≤ n ≤ 1000 , 000 , 000 , 3 ≤ a ≤ 40000 ) n,a;(0≤n≤1000,000,000,3≤a≤40000) n,a;(0n1000,000,000,3a40000)

Output

print two integers b , c b,c b,c if b , c b,c b,c exits;(¥1≤b,c≤1000,000,000¥);

else print two integers − 1 − 1 -1 -1 11 instead.

Sample Input

1
2 3

Sample Output

4 5

题意:

每次两个整数 N 、 a N、a Na,输出符合公式 a n + b n = c n a^n+b^n=c^n an+bn=cn 的一对 b b b c c c
这道题是我们暑假为了打区域赛网络赛训练的第一套题上面的,这个应该是签到题,当时还是yzq告诉我当 n > 2 n>2 n>2 的时候无解,直接费马大定理。时间真快都一年。

  • n = 1 n = 1 n=1,即 a + b = c a + b = c a+b=c,已知 a a a ,令 b = 1 b = 1 b=1 c = a + 1 c = a + 1 c=a+1 即可
  • n = 2 n = 2 n=2,对于 x 2 + y 2 = z 2 x^2+y^2=z^2 x2+y2=z2 ,如果已知 x x x 那么就有 z 2 − y 2 = x 2 z^2−y^2=x^2 z2y2=x2
  • 因为 z > y z > y z>y,所以设 z = y + i z = y + i z=y+i,那么就有: x 2 − i 2 = 2 ∗ i ∗ y x^2−i^2=2∗i∗y x2i2=2iy
  • 只要枚举 i i i ,判断( x 2 − i 2 x^2 - i^2 x2i2 % 2 ∗ i \% 2*i %2i是否可以整除即可。
AC代码:
#include <cstdio>
#include <vector>
#include <queue>
#include <cstring>
#include <cmath>
#include <map>
#include <set>
#include <string>
#include <iostream>
#include <algorithm>
#include <iomanip>
#include <stack>
#include <queue>
using namespace std;
#define sd(n) scanf("%d", &n)
#define sdd(n, m) scanf("%d%d", &n, &m)
#define sddd(n, m, k) scanf("%d%d%d", &n, &m, &k)
#define pd(n) printf("%d\n", n)
#define pc(n) printf("%c", n)
#define pdd(n, m) printf("%d %d", n, m)
#define pld(n) printf("%lld\n", n)
#define pldd(n, m) printf("%lld %lld\n", n, m)
#define sld(n) scanf("%lld", &n)
#define sldd(n, m) scanf("%lld%lld", &n, &m)
#define slddd(n, m, k) scanf("%lld%lld%lld", &n, &m, &k)
#define sf(n) scanf("%lf", &n)
#define sc(n) scanf("%c", &n)
#define sff(n, m) scanf("%lf%lf", &n, &m)
#define sfff(n, m, k) scanf("%lf%lf%lf", &n, &m, &k)
#define ss(str) scanf("%s", str)
#define rep(i, a, n) for (int i = a; i <= n; i++)
#define per(i, a, n) for (int i = n; i >= a; i--)
#define mem(a, n) memset(a, n, sizeof(a))
#define debug(x) cout << #x << ": " << x << endl
#define pb push_back
#define all(x) (x).begin(), (x).end()
#define fi first
#define se second
#define mod(x) ((x) % MOD)
#define gcd(a, b) __gcd(a, b)
#define lowbit(x) (x & -x)
typedef pair<int, int> PII;
typedef long long ll;
typedef unsigned long long ull;
typedef long double ld;
const int MOD = 1e9 + 7;
const double eps = 1e-9;
const ll INF = 0x3f3f3f3f3f3f3f3fll;
const int inf = 0x3f3f3f3f;
inline int read()
{
    int ret = 0, sgn = 1;
    char ch = getchar();
    while (ch < '0' || ch > '9')
    {
        if (ch == '-')
            sgn = -1;
        ch = getchar();
    }
    while (ch >= '0' && ch <= '9')
    {
        ret = ret * 10 + ch - '0';
        ch = getchar();
    }
    return ret * sgn;
}
inline void Out(int a) //Êä³öÍâ¹Ò
{
    if (a > 9)
        Out(a / 10);
    putchar(a % 10 + '0');
}

ll gcd(ll a, ll b)
{
    return b == 0 ? a : gcd(b, a % b);
}

ll lcm(ll a, ll b)
{
    return a * b / gcd(a, b);
}
///快速幂m^k%mod
ll qpow(ll a, ll b, ll mod)
{
    if (a >= mod)
        a = a % mod + mod;
    ll ans = 1;
    while (b)
    {
        if (b & 1)
        {
            ans = ans * a;
            if (ans >= mod)
                ans = ans % mod + mod;
        }
        a *= a;
        if (a >= mod)
            a = a % mod + mod;
        b >>= 1;
    }
    return ans;
}

// 快速幂求逆元
int Fermat(int a, int p) //费马求a关于b的逆元
{
    return qpow(a, p - 2, p);
}

///扩展欧几里得
int exgcd(int a, int b, int &x, int &y)
{
    if (b == 0)
    {
        x = 1;
        y = 0;
        return a;
    }
    int g = exgcd(b, a % b, x, y);
    int t = x;
    x = y;
    y = t - a / b * y;
    return g;
}

///使用ecgcd求a的逆元x
int mod_reverse(int a, int p)
{
    int d, x, y;
    d = exgcd(a, p, x, y);
    if (d == 1)
        return (x % p + p) % p;
    else
        return -1;
}

///中国剩余定理模板0
ll china(int a[], int b[], int n) //a[]为除数,b[]为余数
{
    int M = 1, y, x = 0;
    for (int i = 0; i < n; ++i) //算出它们累乘的结果
        M *= a[i];
    for (int i = 0; i < n; ++i)
    {
        int w = M / a[i];
        int tx = 0;
        int t = exgcd(w, a[i], tx, y); //计算逆元
        x = (x + w * (b[i] / t) * x) % M;
    }
    return (x + M) % M;
}

#include <cstdio>
typedef long long ll;
int main()
{
    int t;
    sd(t);
    while (t--)
    {
        ll n, a, b, c;
        sldd(n, a);
        if (n == 1)
        {
            pldd(1, 1 + a);
        }
        else if (n == 2)
        {
            if (a % 2 == 1)
            {
                ll res = (a - 1) / 2;
                b = 2 * res * res + 2 * res;
                c = b + 1;
                pldd(b, c);
            }
            else
            {
                ll res = a / 2 - 1;
                b = res * res + 2 * res;
                c = b + 2;
                pldd(b, c);
            }
        }
        else
            printf("-1 -1 \n");
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值