HDU 6441 Find Integer(费马大定理)

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.
Input
one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)
Output
print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.
Sample Input
1
2 3
Sample Output
4 5
题解:此题考察费马大定理,当n>=3时,a的n次方+b的n次方=c的n次方,将没有整数解,所以这个题只需判断,n=1和n=2的情况就好了,我们接下来,还要提一下,当n=2时,你需要点开
https://wenku.baidu.com/view/8282f1b669eae009591bec85.html
这个神奇的链接看一下。

AC代码:

#include<stdio.h>
int main()
{
	long long T,n,a;
	scanf("%lld",&T);
	while(T--)
	{
		scanf("%lld%lld",&n,&a);
		if(n>=3||n==0)
		{
			printf("-1 -1\n");
		}
		else if(n==1)
		{
			printf("%lld %lld\n",a+1,2*a+1);
		}
		else if(n==2)
		{
			if(a%2!=0)
			{
				printf("%lld %lld\n",a*(a/2)+a/2,a*(a/2)+a/2+1);
			}
			else
			{
				printf("%lld %lld\n",(a*(a/2))/2-1,(a*(a/2))/2+1);
			}
		}
	}
	return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值