HDU 6441 Find Integer 【费马大定理】


传送门:HDU 6441


Find Integer
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Problem Description
people in USSS love math very much, and there is a famous math problem .
give you two integers n,a,you are required to find 2 integers b,c such that a n + b n = c n a^n+b^n=c^n an+bn=cn.

Input
one line contains one integer T;(1≤T≤1000000)
next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

Output
print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);
else print two integers -1 -1 instead.

Sample Input
1
2 3

Sample Output
4 5



题解:
这题如果知道费马大定理的话就是一道水题。

费马大定理:
当整数 n>2 时,关于 x,y,z 的方程 x n + y n = z n x^n+y^n=z^n xn+yn=zn 没有正整数解。

  • 当 n > 2 时,直接输出 -1 -1 ;
  • 当 n = 0,也是无解,输出-1 -1;
  • 当 n = 1,即 a + b = c,已知 a ,令 b = 1,c = a + 1 即可
  • 当 n = 2,对于 x 2 + y 2 = z 2 x^2 + y^2 = z^2 x2+y2=z2,如果已知x,那么就有 z 2 − y 2 = x 2 z^2-y^2=x^2 z2y2=x2
    因为 z > y,所以设 z = y + i
    那么就有:
    x 2 − i 2 = 2 ∗ i ∗ y x^2 - i^2 = 2*i*y x2i2=2iy
    只要枚举 i ,判断(x^2 - i^2)% 2*i 是否可以整除即可


AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#define ll long long
#define inf 0x3f3f3f3f
int t;
ll n;
ll a;
int main()
{
  scanf("%d",&t);
  while(t--)
  {
    scanf("%I64d%I64d",&n,&a);
    if(n>2||n==0)
    {
      printf("-1 -1\n");
    }
    else if(n==1)
    {
      printf("1 %I64d\n",1+a);
    }
    else
    {
      a=a*a;
      ll b,c;
      for(ll i=1;;i++)
      {
        if((a-i*i)%(2*i)==0)
        {
          b=(a-i*i)/(2*i);
          c=b+i;
          break;
        }
      }
      printf("%I64d %I64d\n",b,c);
    }
  }
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值