PAT甲级【 A1043 Is It a Binary Search Tree 】

题目描述

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.
Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

输入描述

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

输出描述

For each test case, first print in a line “YES” if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or “NO” if not. Then if the answer is “YES”, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

输入样例

7
8 6 5 7 10 8 11

输出样例

YES
5 7 6 8 11 10 8

题目大意

给一个整数序列,判断其是否为对应二叉查找树的前序遍历序列或者为其镜像树的前序遍历序列。所谓镜像树,是指将该树上的每个结点的左右子树互换形成的二叉树。如果是,则输出对应树的后序遍历序列,否则输出NO。

分析

根据结点序列,重建这棵BST树。定义三个vector数组,分别保存BST树的前序序列,对应镜像树的前序序列,以及保存对应树的后序序列。然后将该序列与输入序列进行比较,若符合树的先序或者镜像树的先序,则按要求输出对应的后序序列。求前序序列和后序序列,进行前序或后序遍历即可,镜像树的前序序列按根,右,左的次序遍历即可,后序序列则按右,左,根的次序遍历即可。

#include <iostream>
#include <vector>

using namespace std;
typedef struct node {
    int data;
    struct node *lchild, *rchild;
};
vector<int> v1, v2, v3;//v1保存前序序列,v2保存镜像树前序序列,v3保存后序序列

void createBST(node *&T, int v) { //重建BST树
    if (T == NULL) {
        T = (node *) malloc(sizeof(node));
        T->data = v;
        T->lchild = NULL;
        T->rchild = NULL;
        return;
    }
    if (T->data > v)
        createBST(T->lchild, v);
    else
        createBST(T->rchild, v);
}

void preTraverse(node *T) { //先序遍历
    if (T != NULL) {
        v1.push_back(T->data);
        preTraverse(T->lchild);
        preTraverse(T->rchild);
    }
}

void MirrorTraverse(node *T) {//镜像先序遍历
    if (T != NULL) {
        v2.push_back(T->data);
        MirrorTraverse(T->rchild);
        MirrorTraverse(T->lchild);
    }
}

void HostTraverse(node *T) {//后序遍历
    if (T != NULL) {
        HostTraverse(T->lchild);
        HostTraverse(T->rchild);
        v3.push_back(T->data);
    }
}

void HostTraverseMirror(node *T) {//镜像树后序遍历
    if (T != NULL) {
        HostTraverseMirror(T->rchild);
        HostTraverseMirror(T->lchild);
        v3.push_back(T->data);
    }
}

int main() {
    int N;
    cin >> N;
    node *T = NULL;
    vector<int> Data(N);
    for (int i = 0; i < N; ++i) {
        cin >> Data[i];
    }
    for (int j = 0; j < N; ++j) {
        createBST(T, Data[j]);
    }
    preTraverse(T);
    MirrorTraverse(T);
    if (v1 == Data) {
        HostTraverse(T);
        cout << "YES" << endl;
        for (int i = 0; i < N; ++i) {
            if (i != N - 1)
                cout << v3[i] << " ";
            else cout << v3[i];
        }
    } else if (v2 == Data) {
        HostTraverseMirror(T);
        cout << "YES" << endl;
        for (int i = 0; i < N; ++i) {
            if (i != N - 1)
                cout << v3[i] << " ";
            else cout << v3[i];
        }
    } else cout << "NO";
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Missヾaurora

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值