Parity game -离散化+带权并查集

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

题意:现在有一个长度为n的零一串,给出m次查询,每次查询格式为:从第u位到第v位的1的个数为奇数或者偶数,其中

“even” 是偶数的意思“odd” 是奇数的意思。问,前几个查询是正确的,也就是第一个错误的查询的前一条查询是第几次查询。

典型的带权并查集题,算是简单的并查集,但是由于这题的数据过大,需要离散化,不会离散化的我一脸懵逼啊,各种百度,发现方法有很多,这么懒的我当然是找个简单的学了。

总的来说,先将数字放入一个数组,然后排序,再用unique(sb,sb+w)-sb;去重,sb为数组名, 这里将返回一个数,数字的含义是有几个不重复得数,但是注意,这个函数只会将不重复的数移到前面,重复的数字还堆积在后面。

例如:1 2 2 3 4 4 5

函数会将其变为1 2 3 4 5 2 4

并且返回的数字xx=5;

然后我们就要借用lower_bound

关于它的定义:

lower_bound()函数需要加载头文件#include<algorithm>,其基本用途是查找有序区间中第一个大于或等于某给定值的元素的位置,其中排序规则可以通过二元关系来表示。

x=lower_bound(sb,sb+xx,p[i].a)-sb;  //注意这里是从xx-1往前搜索

这样使用,从xx-1往前搜索,找到第一个大于等于p[i].a得数,返回下标

就这样啦~

然后贴个代码~

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct ll
{
    int a,b,c;
} p[10010];
int sb[10010],flag;
struct pp
{
    int dad,re;
} k[10010];
int chushi(int xx)
{
    for(int i=0; i<=xx; i++)
    {
        k[i].dad=i;
        k[i].re=0;
    }
}
int find(int x)
{
    int temp=k[x].dad;
    if(k[x].dad!=x)
    {
        k[x].dad=find(k[x].dad);
        k[x].re=(k[x].re+k[temp].re)%2;
    }
    return k[x].dad;
}
int join(int a,int b,int c)
{
    int x,y;
    x=find(a);
    y=find(b);
    if(x!=y)
    {
        k[y].dad=x;
        k[y].re=(c+k[a].re+k[b].re)%2;
    }
    else if(x==y&&abs(k[b].re-k[a].re)!=c)
    {
        flag=1;
    }
}
int main()
{
    int n,m,x;
    char s[10];
    while(~scanf("%d%d",&n,&m))
    {
        flag=0;
        int w=0,op;
        for(int i=1; i<=m; i++)
        {
            scanf("%d%d%s",&p[i].a,&p[i].b,s);
            p[i].a--;
            sb[w++]=p[i].a;
            sb[w++]=p[i].b;
            x=strcmp(s,"even");
            if(x==0)
                p[i].c=0;
            else
                p[i].c=1;
        }
        sort(sb,sb+w);
        int xx=unique(sb,sb+w)-sb;
        chushi(xx);
        for(int i=1; i<=m; i++)
        {
            int x=lower_bound(sb,sb+xx,p[i].a)-sb;
            int y=lower_bound(sb,sb+xx,p[i].b)-sb;
            int o=p[i].c;
            join(x,y,o);
            if(flag==1)
            {
                op=i-1;
                break;
            }
        }
        if(flag==1)
            printf("%d\n",op);
        else
            printf("%d\n",m);
    }
}

 

 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值