POJ 1733 Parity game (带权并查集+离散化)

题意:

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

思路:

做的第一个带权并查集,这个题比较重要的一点思维就是,只要求判断区间的1的个数是偶数还是奇数,所以,有影响的只是相邻的区间[a,b][b+1,c]->[a,c],类似这一种,才可能产生矛盾,

所以,只需要对于给出的区间进行并查集,将每个区间合并,连续的区间也合并起来,

所以,在我的输入内有a--,这是区间向左边合并,所以,后面头结点不同的区间合并时也要注意。左边的点作为头结点,(自己画图,跟着题解理解才可以,)

再就是比较巧妙的一点是,将求1的个数的奇偶性直接用^就解决 了,也是学到了。感觉这个题对于并查集小白还是很不错的。详细解释见代码。

还有就是离散化,用map的运用也比较巧妙。表示第一次这么用。。

代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<map>
using namespace std;
int n,m,ans,con[20005],f[20005];
int fin(int rt)
{
    if(rt==f[rt]) return rt;
    int x=f[rt];
    f[rt]=fin(x);///带权并查集,con[x]表示x到其头结点的1的个数的奇偶数
    con[rt]^=con[x];
    return f[rt];
}
map<int,int>ma;
char ch[5];
int main()
{
    scanf("%d",&n);
    scanf("%d",&m);
    int ok=0,t=0,num=0,a,b;
    while(m--)
    {
        scanf("%d%d%s",&a,&b,ch);
        a--;///将连续的区间合并。例如[1,2][3,4]这样的区间,不然无法判断,不连续的区间不影响。中间间断可以任意选择是否放1即可影响答案
        if(ok) continue;
        if(ch[0]=='o') t=1;
        else t=0;
        if(ma.find(a)==ma.end()) ma[a]=++num,f[num]=num;
        if(ma.find(b)==ma.end()) ma[b]=++num,f[num]=num;
        int l=ma[a],r=ma[b];
        int u=fin(l),v=fin(r);
        if(u==v)
        {
            if(con[l]^con[r]==t)///拥有公共头结点,[l,r]的1的个数==[u,l]+[v,r]的1的个数,(只需判断奇数偶数个,^就可以)
                ans++;///奇偶数相同,则此条符合
            else ok=1;///矛盾,后面的都不用判了
        }
        else
        {
            f[v]=u;///没有公共头结点,将l,r连线,uv之间的1的奇偶性就是[u,l]+[l,r]+[r,v]
            con[v]=con[l]^con[r]^t;///三段的^值,就是v到u的区间内的1的个数。
            ans++;///再就是这里头结点的选择要与前面连续区间合并的是左合并还是右合并对应好
        }
    }
    printf("%d\n",ans);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值