PTA甲级 1009 Product of Polynomials (C++)

This time, you are supposed to find A × B A×B A×B where A A A and B B B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N 1 a N 1 N 2 a N 2 . . . N K a N K K \quad N_1 \quad a_{N_1} \quad N_2 \quad a_{N_2} \quad ...\quad N_K\quad a_{N_K} KN1aN1N2aN2...NKaNK
where K K K is the number of nonzero terms in the polynomial, N i N_i Ni and a N i ( i = 1 , 2 , ⋯ , K ) a_{N_i}(i=1,2,⋯,K) aNi(i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1 ≤ K ≤ 10 , 0 ≤ N K < ⋯ < N 2 < N 1 ≤ 1000 1≤K≤10, 0≤N_K<⋯<N_2<N_1≤1000 1K10,0NK<<N2<N11000.

Output Specification:

For each test case you should output the product of A A A and B B B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-10 16:50:29
// All rights reserved.

#include <iostream>
#include <vector>

using namespace std;

float ans[2010]{0};

int main(){
    vector<float> pol1, pol2, pol3;

    int num;
    cin >> num;
    pol1.push_back(num);
    for(int i = 0; i < 2 * num; ++i){
        float tmp;
        cin >> tmp;
        pol1.push_back(tmp);
    }

    cin >> num;
    pol2.push_back(num);
    for(int i = 0; i < 2 * num; ++i){
        float tmp;
        cin >> tmp;
        pol2.push_back(tmp);
    }

    for(int i = 1; i < pol2.size(); i += 2){
        for(int j = 1; j < pol1.size(); j += 2){
            int order = pol2[i] + pol1[j];
            float coeff = pol2[i + 1] * pol1[j + 1];

            ans[order] += coeff;
        }
    }

    pol3.push_back(0);

    for(int i = 2009; i >= 0; --i){
        if(ans[i] == 0) continue;
        pol3[0]++;
        pol3.push_back(i);
        pol3.push_back(ans[i]);
    }

    if(pol3[0] == 0){
        cout << 0 << endl;
        return 0;
    }

    cout << pol3[0];
    for(int i = 1; i < pol3.size(); i += 2) printf(" %d %.1f", (int)pol3[i], pol3[i + 1]);

    cout << endl;

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值