This time, you are supposed to find A × B A×B A×B where A A A and B B B are two polynomials.
Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K
N
1
a
N
1
N
2
a
N
2
.
.
.
N
K
a
N
K
K \quad N_1 \quad a_{N_1} \quad N_2 \quad a_{N_2} \quad ...\quad N_K\quad a_{N_K}
KN1aN1N2aN2...NKaNK
where
K
K
K is the number of nonzero terms in the polynomial,
N
i
N_i
Ni and
a
N
i
(
i
=
1
,
2
,
⋯
,
K
)
a_{N_i}(i=1,2,⋯,K)
aNi(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that
1
≤
K
≤
10
,
0
≤
N
K
<
⋯
<
N
2
<
N
1
≤
1000
1≤K≤10, 0≤N_K<⋯<N_2<N_1≤1000
1≤K≤10,0≤NK<⋯<N2<N1≤1000.
Output Specification:
For each test case you should output the product of A A A and B B B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6
Solution:
// Talk is cheap, show me the code
// Created by Misdirection 2021-08-10 16:50:29
// All rights reserved.
#include <iostream>
#include <vector>
using namespace std;
float ans[2010]{0};
int main(){
vector<float> pol1, pol2, pol3;
int num;
cin >> num;
pol1.push_back(num);
for(int i = 0; i < 2 * num; ++i){
float tmp;
cin >> tmp;
pol1.push_back(tmp);
}
cin >> num;
pol2.push_back(num);
for(int i = 0; i < 2 * num; ++i){
float tmp;
cin >> tmp;
pol2.push_back(tmp);
}
for(int i = 1; i < pol2.size(); i += 2){
for(int j = 1; j < pol1.size(); j += 2){
int order = pol2[i] + pol1[j];
float coeff = pol2[i + 1] * pol1[j + 1];
ans[order] += coeff;
}
}
pol3.push_back(0);
for(int i = 2009; i >= 0; --i){
if(ans[i] == 0) continue;
pol3[0]++;
pol3.push_back(i);
pol3.push_back(ans[i]);
}
if(pol3[0] == 0){
cout << 0 << endl;
return 0;
}
cout << pol3[0];
for(int i = 1; i < pol3.size(); i += 2) printf(" %d %.1f", (int)pol3[i], pol3[i + 1]);
cout << endl;
return 0;
}