PTA甲级 1020 Tree Traversals (C++)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 30 ) N (≤30) N(30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-12 15:28:46
// All rights reserved.

#include <iostream>
#include <vector>
#include <queue>
#include <unordered_map>

using namespace std;

int n;
vector<int> post;
vector<int> in;
unordered_map<int, bool> hasFound;

struct Node{
    int num;

    Node *left;
    Node *right;

    Node(int n = -1, Node* l = NULL, Node* r = NULL){
        num = n; 
        left = l; 
        right = r;
    }

    ~Node(){}
};

void findChildren(Node *r){
    // printf("finding %d's children\n", r -> num);

    int inPos, postPos;

    for(int i = 0; i < n; ++i){
        if(in[i] == r -> num){
            inPos = i;
            break;
        }
    }

    for(int i = 0; i < n; ++i){
        if(post[i] == r -> num){
            postPos = i;
            break;
        }
    }
    
    bool findLeft = false, findRight = false;

    for(int i = postPos - 1; i >= 0; --i){
        for(int j = 0; j < inPos; ++j){
            if(post[i] == in[j] && hasFound[post[i]] == false){
                r -> left = new Node(post[i], NULL, NULL);
                // printf("%d's left children is %d\n", r -> num, post[i]);
                findLeft = true;
                hasFound[post[i]] = true;
                break;
            }
        }
        if(findLeft) break;
    }

    for(int i = postPos - 1; i >= 0; --i){
        for(int j = inPos + 1; j < n; ++j){
            if(post[i] == in[j] && hasFound[post[i]] == false){
                r -> right = new Node(post[i], NULL, NULL);
                // printf("%d's right children is %d\n", r -> num, post[i]);
                findRight = true;
                hasFound[post[i]] = true;
                break;
            }
        }
        if(findRight) break;
    }

    if(r -> left != NULL) findChildren(r -> left);
    if(r -> right != NULL) findChildren(r -> right);

    return;
}

int main(){

    cin >> n;
    post.resize(n);
    in.resize(n);

    for(int i = 0; i < n; ++i) cin >> post[i];
    for(int i = 0; i < n; ++i){
        cin >> in[i];
        hasFound[in[i]] = false;
    }

    Node *root = new Node(post[n - 1], NULL, NULL);
    hasFound[post[n - 1]] = true;

    findChildren(root);
   
    queue<Node*> q;
    q.push(root);

    while(!q.empty()){
        printf("%d", q.front() -> num);
        if(q.front() -> left != NULL) q.push(q.front() -> left);
        if(q.front() -> right != NULL) q.push(q.front() -> right);
        
        q.pop();
        if(q.empty()) printf("\n");
        else printf(" ");
    }

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值