PAT 甲级 1020 Tree Traversals (25分)

题目

1020 Tree Traversals (25分)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

题目大意

给出树的后序、中序遍历,求出树的层序遍历

思路

采用递归构造树的思路,用index表示下标,根结点下标为1开始,父节点下标为index,左孩子为2 * index,右孩子为2 * index+1。

代码

#include<bits/stdc++.h>
using namespace std;
int N, maxlevel=0;
map<int, int> tree;
vector<int> post, in;
void create(int root, int left, int right, int index){
    if(left > right) return;
    int i=left;
    while(i<right && post[root] != in[i]) i++;
    tree[index] = post[root];
    create(root-right+i-1, left, i-1, 2*index);
    create(root-1, i+1, right, 2*index+1);
}
int main(int argc, const char * argv[]) {
    cin>>N;
    post.resize(N);
    in.resize(N);
    for(int i=0; i<N; i++)
        cin>>post[i];
    for(int i=0; i<N; i++)
        cin>>in[i];
    create(N-1, 0, N-1, 1);
    bool flag = true;
    for(auto it : tree){
        printf("%s%d", flag?"":" ", it.second);
        flag = false;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值