PTA甲级 1066 Root of AVL Tree (C++)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
在这里插入图片描述

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N ( ≤ 20 ) N (≤20) N(20) which is the total number of keys to be inserted. Then N N N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-20 11:58:29
// All rights reserved.

#include <iostream>
#include <vector>

using namespace std;

struct Node{
    int key;
    Node* left;
    Node* right;
    int height;

    Node(int k = -1, Node* l = NULL, Node* r = NULL){
        key = k;
        left = l;
        right = r;
        height = 1;
    }

    ~Node(){}
};

Node* LL(Node* r){
    Node *tmp = r -> left;
    r -> left = tmp -> right;
    tmp -> right = r;

    return tmp;
}

Node* RR(Node *r){
    Node *tmp = r -> right;
    r -> right = tmp -> left;
    tmp -> left = r;

    return tmp;
}

Node* LR(Node* r){
    r -> left = RR(r -> left);
    return LL(r);
}

Node* RL(Node* r){
    r -> right = LL(r -> right);
    return RR(r);
}

int height(Node *r){
    if(r == NULL) return 0;
    else return max(height(r -> left), height(r -> right)) + 1;
}

Node* insert(Node* r, int key){
    // 分成几种情况:
    // 左孩子的左子树——LL
    // 右孩子的右子树——RR
    // 右孩子的左子树——RL
    // 左孩子的右子树——LR

    if(r == NULL){
        r = new Node(key, NULL, NULL);
        return r;
    }

    if(key < r -> key){
        r -> left = insert(r -> left, key);

        // 插入了左孩子
        if(height(r -> left) - height(r -> right) == 2){
            if(key < r -> left -> key) r = LL(r);
            else r = LR(r);

            return r;
        }
    }
    else if(key > r -> key){
        r -> right = insert(r -> right, key);

        // 插入了右孩子
        if(height(r -> right) - height(r -> left) == 2){
            if(key > r -> right -> key) r = RR(r);
            else r = RL(r);

            return r;
        }
    }

    return r;
}



int main(){
    
    int n;

    scanf("%d", &n);
    Node *root;

    for(int i = 0; i < n; ++i){
        int tmp;
        scanf("%d", &tmp);
        
        if(i == 0) root = new Node(tmp, NULL, NULL);

        else root = insert(root, tmp);
    }

    printf("%d", root -> key);

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值