PTA甲级 1077 Kuchiguse (C++)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N ( 2 ≤ N ≤ 100 ) N (2≤N≤100) N(2N100). Following are N N N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N N N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-22 16:32:32
// All rights reserved.

#include <iostream>
#include <vector>

using namespace std;

int main(){
    int n;
    scanf("%d\n", &n);
    string sentence, suffix;
    int suffixLen;

    for(int i = 0; i < n; ++i){
        if(i == 0){
            getline(cin, suffix);
            suffixLen = suffix.length();

            continue;
        }

        getline(cin, sentence);        

        // 找 suffix 和 sentence 之间的后缀
        suffixLen = 0;

        while(suffixLen < suffix.length() && suffixLen < sentence.length() && suffix[suffix.length() - suffixLen - 1] == sentence[sentence.length() - suffixLen - 1]) suffixLen++;

        if(suffixLen == 0) break;
        suffix = suffix.substr(suffix.length() - suffixLen, suffixLen);

    }

    if(suffixLen == 0) printf("nai\n");
    else printf("%s\n", suffix.c_str());

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值