PTA甲级 1086 Tree Traversals Again (C++)

该博客介绍了如何通过非递归方式利用栈实现二叉树的前序遍历和中序遍历,并根据给定的前序和中序遍历序列生成后序遍历序列。具体实现中,前序遍历的顺序对应push操作,中序遍历的顺序对应pop操作,通过这些操作构建出二叉树结构,并输出对应的后序遍历序列。
摘要由CSDN通过智能技术生成

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N ( ≤ 30 ) N (≤30) N(30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N N N). Then 2 N 2N 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

Caution:

其实就是根据前序遍历和中序遍历求二叉树的后序遍历。
push的顺序是前序遍历,pop的顺序是中序遍历。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-23 17:20:24
// All rights reserved.

#include <iostream>
#include <vector>
#include <stack>
#include <algorithm>

using namespace std;

vector<int> midOrder, preOrder, postOrder;

struct Node{
    int key;
    Node *left;
    Node *right;

    Node(int k = -1, Node *l = NULL, Node *r = NULL){
        key = k;
        left = l;
        right = r;
    }

    ~Node(){}
};

void findChildren(Node *r, int left, int right){
    if(r == NULL) return;

    int posInMid = find(midOrder.begin(), midOrder.end(), r -> key) - midOrder.begin();
    int posInPre = find(preOrder.begin(), preOrder.end(), r -> key) - preOrder.begin();

    // left ~ posInMid - 1 is left subTree
    // posInMid + 1 ~ right is right subTree
    
    if(posInMid > left) r -> left = new Node(preOrder[posInPre + 1], NULL, NULL);
    // left subtree is not null
        
    if(posInMid < right) r -> right = new Node(preOrder[posInPre + 1 + posInMid - left], NULL, NULL);
    // right subtree is not null

    findChildren(r -> left, left, posInMid - 1);
    findChildren(r -> right, posInMid + 1, right);
}

void postTraverse(Node *r){
    if(r -> left != NULL) postTraverse(r -> left);
    if(r -> right != NULL) postTraverse(r -> right);
    postOrder.push_back(r -> key);
}

int main(){
    int n;
    scanf("%d", &n);

    stack<int> st;
    midOrder.clear();
    preOrder.clear();
    postOrder.clear();

    for(int i = 0; i < 2 * n; ++i){
        string op;
        int tmp;

        cin >> op;
        if(op == "Push"){
            cin >> tmp;
            st.push(tmp);
            preOrder.push_back(tmp);
        }
        else{
            tmp = st.top();
            midOrder.push_back(tmp);
            st.pop();
        }
    }

    Node *root = new Node(preOrder[0], NULL, NULL);
    
    findChildren(root, 0, n - 1);
    
    postTraverse(root);

    for(int i = 0; i < n; ++i){
        if(i == n - 1) printf("%d\n", postOrder[i]);
        else printf("%d ", postOrder[i]);
    }

    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值