PTA甲级 1127 ZigZagging on a Tree (C++)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 30 ) N (≤30) N(30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1

Sample Output:

1 11 5 8 17 12 20 15

Caution:

用两个栈来回倒,核心就是下面两行关于进栈顺序的注释。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-28 12:02:47
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>
#include <unordered_map>
#include <stack>

using namespace std;

int n;
vector<int> postOrder, inOrder, zigzagOrder;
unordered_map<int, bool> visited;

struct Node{
    int key;
    Node *left;
    Node *right;

    Node(int k = -1){
        key = k;
        left = NULL;
        right = NULL;
    }
    ~Node(){}
};

void findChildren(Node *r){
    if(r == NULL) return;

    visited[r -> key] = true;
    int posInMid = find(inOrder.begin(), inOrder.end(), r -> key) - inOrder.begin();
    int posInPost = find(postOrder.begin(), postOrder.end(), r -> key) - postOrder.begin();

    int left = -1, right = -1;

    for(int i = posInPost - 1; i >= 0 && visited[postOrder[i]] == false; --i){

        if(i == posInPost - 1){
            if(find(inOrder.begin(), inOrder.end(), postOrder[i]) - inOrder.begin() > posInMid) right = postOrder[i];
            else{
                left = postOrder[i];
                break;
            }
        }

        if(find(inOrder.begin(), inOrder.end(), postOrder[i]) - inOrder.begin() < posInMid){
            left = postOrder[i];
            break;
        }
    }

    if(left != -1) r -> left = new Node(left);
    if(right != -1) r -> right = new Node(right);

    findChildren(r -> left);
    findChildren(r -> right);
}

void preOrder(Node *r){
    if(r == NULL) return;

    cout << r -> key << ' ';
    preOrder(r -> left);
    preOrder(r -> right);
}

int main(){
    scanf("%d", &n);
    inOrder.resize(n);
    postOrder.resize(n);
    zigzagOrder.clear();

    for(int i = 0; i < n; ++i) scanf("%d", &inOrder[i]);
    for(int i = 0; i < n; ++i) scanf("%d", &postOrder[i]);

    Node *root = new Node(postOrder[n - 1]);

    findChildren(root);
    // preOrder(root);

    stack<Node*> s1, s2;
    // 在 s1 出栈则以先左后右的顺序进栈 s2
    // 在 s2 出栈则以先右后左的顺序进栈 s1
    s2.push(root);
    while(!s1.empty() || !s2.empty()){
        if(s1.empty()){
            // s2 出栈
            while(!s2.empty()){
                Node *tmp = s2.top();
                zigzagOrder.push_back(tmp -> key);

                if(tmp -> right != NULL) s1.push(tmp -> right);
                if(tmp -> left != NULL) s1.push(tmp -> left);
                
                s2.pop();
            }
        }
        else{
            while(!s1.empty()){
                Node *tmp = s1.top();
                zigzagOrder.push_back(tmp -> key);

                if(tmp -> left != NULL) s2.push(tmp -> left);
                if(tmp -> right != NULL) s2.push(tmp -> right);

                s1.pop();
            }
        }
    }

    for(int i = 0; i < n; ++i){
        if(i == n - 1) printf("%d\n", zigzagOrder[i]);
        else printf("%d ", zigzagOrder[i]);
    }

    return 0;
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值