PTA甲级 1154 Vertex Coloring (C++)

该程序解决了一个图论问题,检查给定的顶点着色是否为有效的k着色。输入包含图的边信息和多个着色方案,输出每个方案是否构成适当着色。示例输入包括一个10节点图,11条边和4个着色方案,程序判断这些方案是否为适当的k着色。
摘要由CSDN通过智能技术生成

A proper vertex coloring is a labeling of the graph’s vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k k k colors is called a (proper) k k k-coloring.

Now you are supposed to tell if a given coloring is a proper k k k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N N N and M M M (both no more than 1 0 4 10^4 104), being the total numbers of vertices and edges, respectively. Then M M M lines follow, each describes an edge by giving the indices (from 0 to N − 1 N−1 N1) of the two ends of the edge.

After the graph, a positive integer K ( ≤ 100 ) K (≤ 100) K(100) is given, which is the number of colorings you are supposed to check. Then K K K lines follow, each contains N N N colors which are represented by non-negative integers in the range of int. The i i i-th color is the color of the i i i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-31 11:07:59
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>

using namespace std;

int main(){
    int n, m;
    scanf("%d %d", &n, &m);

    vector<vector<int>> edges(n);
    for(int i = 0; i < m; ++i){
        int id1, id2;
        scanf("%d %d", &id1, &id2);

        edges[id1].push_back(id2);
    }

    int k;
    scanf("%d", &k);
    for(int i = 0; i < k; ++i){
        unordered_map<int, bool> validColors;
        unordered_map<int, int> colorsPairs;
        int cnt = 0;
        bool valid = true;

        for(int j = 0; j < n; ++j){
            int color;
            scanf("%d", &color);

            if(validColors[color] == false){
                cnt++;
                validColors[color] = true;
            }

            colorsPairs[j] = color;
        }

        for(int j = 0; j < n; ++j){
            int tmp = colorsPairs[j];
            for(int k = 0; k < edges[j].size(); ++k){
                if(tmp == colorsPairs[edges[j][k]]){
                    valid = false;
                    break;
                }
            }
        }

        if(valid) printf("%d-coloring\n", cnt);
        else printf("No\n");
    }


    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

负反馈循环

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值