A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))
Now it is your job to judge if a given subset of vertices can form a maximal clique.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N v ( ≤ 200 ) N_v (≤ 200) Nv(≤200), the number of vertices in the graph, and N e N_e Ne, the number of undirected edges. Then N e N_e Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to N v N_v Nv.
After the graph, there is another positive integer M ( ≤ 100 ) M (≤ 100) M(≤100). Then M M M lines of query follow, each first gives a positive number K ( ≤ N v ) K (≤ N_v) K(≤Nv), then followed by a sequence of K K K distinct vertices. All the numbers in a line are separated by a space.
Output Specification:
For each of the M queries, print in a line Yes
if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal
; or if it is not a clique at all, print Not a Clique
.
Sample Input:
8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1
Sample Output:
Yes
Yes
Yes
Yes
Not Maximal
Not a Clique
Caution:
题目数据量并不大,用暴力解法就可以。
Solution:
// Talk is cheap, show me the code
// Created by Misdirection 2021-09-01 10:11:53
// All rights reserved.
#include <iostream>
#include <vector>
#include <unordered_map>
using namespace std;
int graph[205][205] = {0};
int vertices[205];
int main(){
int nv, ne;
scanf("%d %d", &nv, &ne);
int id1, id2;
for(int i = 0; i < ne; ++i){
scanf("%d %d", &id1, &id2);
graph[id1][id2] = 1;
graph[id2][id1] = 1;
}
int k;
scanf("%d", &k);
for(int i = 0; i < k; ++i){
int num;
scanf("%d", &num);
int flag = -1;
// flag = 0 表示 【不是 clique】
// flag = 1 表示 【是 clique 但不是最大的】
// flag = 2 表示 【是最大的 clique】
unordered_map<int, bool> isChosen;
for(int j = 0; j < num; ++j){
scanf("%d", &vertices[j]);
isChosen[vertices[j]] = true;
}
for(int j = 0; j < num; ++j){
for(int k = j + 1; k < num; ++k){
if(graph[vertices[j]][vertices[k]] == 0){
flag = 0;
break;
}
}
}
if(flag == -1){
flag = 2;
for(int j = 1; j <= nv; ++j){
if(!isChosen[j]){
int k;
for(k = 0; k < num; ++k){
if(graph[j][vertices[k]] == 0) break;
}
if(k == num){
flag = 1;
break;
}
}
}
}
if(flag == 0) printf("Not a Clique\n");
else if(flag == 1) printf("Not Maximal\n");
else printf("Yes\n");
}
return 0;
}